aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2004-10-18 23:11:32 +0800
committerthierry <thierry@FreeBSD.org>2004-10-18 23:11:32 +0800
commitd133c5a8873b169450cbaf1fffa3118d8b5765cc (patch)
treec60cb85852207bb67fcd641db7cdd3e0b41c688b /benchmarks
parentb2ee0fe3ce2e3189abb5c1eeef52a6ca56c4fecd (diff)
downloadfreebsd-ports-gnome-d133c5a8873b169450cbaf1fffa3118d8b5765cc.tar.gz
freebsd-ports-gnome-d133c5a8873b169450cbaf1fffa3118d8b5765cc.tar.zst
freebsd-ports-gnome-d133c5a8873b169450cbaf1fffa3118d8b5765cc.zip
Add pear-Benchmark 1.2.1, framework to benchmark PHP scripts or
function calls. PR: 71528 Submitted by: Antônio Carlos Venâncio Júnior
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/Makefile1
-rw-r--r--benchmarks/pear-Benchmark/Makefile26
-rw-r--r--benchmarks/pear-Benchmark/distinfo2
-rw-r--r--benchmarks/pear-Benchmark/pkg-descr3
4 files changed, 32 insertions, 0 deletions
diff --git a/benchmarks/Makefile b/benchmarks/Makefile
index 47cf6c598e02..611b2d51d3f6 100644
--- a/benchmarks/Makefile
+++ b/benchmarks/Makefile
@@ -20,6 +20,7 @@
SUBDIR += netperf
SUBDIR += netpipe
SUBDIR += nttcp
+ SUBDIR += pear-Benchmark
SUBDIR += pipebench
SUBDIR += pnetmark
SUBDIR += polygraph
diff --git a/benchmarks/pear-Benchmark/Makefile b/benchmarks/pear-Benchmark/Makefile
new file mode 100644
index 000000000000..2ddc1bc59721
--- /dev/null
+++ b/benchmarks/pear-Benchmark/Makefile
@@ -0,0 +1,26 @@
+# Ports collection makefile for: pear-Benchmark
+# Date created: 09 September 2004
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Benchmark
+PORTVERSION= 1.2.1
+CATEGORIES= benchmarks devel www pear
+
+MAINTAINER= antonio@php.net
+COMMENT= Framework to benchmark PHP scripts or function calls
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= Benchmark
+FILES= Timer.php Iterate.php Profiler.php
+DOCS= timer_example.php
+
+_DOCSDIR= doc
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/benchmarks/pear-Benchmark/distinfo b/benchmarks/pear-Benchmark/distinfo
new file mode 100644
index 000000000000..e65b47b1ee06
--- /dev/null
+++ b/benchmarks/pear-Benchmark/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/Benchmark-1.2.1.tgz) = 47114bf9e7ff959d8806a70de9ef36b7
+SIZE (PEAR/Benchmark-1.2.1.tgz) = 5732
diff --git a/benchmarks/pear-Benchmark/pkg-descr b/benchmarks/pear-Benchmark/pkg-descr
new file mode 100644
index 000000000000..c57fbd25a229
--- /dev/null
+++ b/benchmarks/pear-Benchmark/pkg-descr
@@ -0,0 +1,3 @@
+Framework to benchmark PHP scripts or function calls.
+
+WWW: http://pear.php.net/package/Benchmark/