aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-11-03 18:42:12 +0800
committermarino <marino@FreeBSD.org>2014-11-03 18:42:12 +0800
commitdf12bff115990d04929ac599c9b60cd092fbb677 (patch)
treedf4ff5523b3526907866ed02c078f17779e335a4 /benchmarks
parent4ec57d6f2368927127b15f53b5afc324baf04391 (diff)
downloadfreebsd-ports-gnome-df12bff115990d04929ac599c9b60cd092fbb677.tar.gz
freebsd-ports-gnome-df12bff115990d04929ac599c9b60cd092fbb677.tar.zst
freebsd-ports-gnome-df12bff115990d04929ac599c9b60cd092fbb677.zip
benchmarks/lmbench: Unbreak on all platforms
The PLIST_SUB hack that worked for years stopped working with recent changes to PLIST_SUB handling. We don't need to run a script to figure out where the files are getting installed. We can recreate it from ARCH, OPSYS, and OSREL variables.
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/lmbench/Makefile10
1 files changed, 2 insertions, 8 deletions
diff --git a/benchmarks/lmbench/Makefile b/benchmarks/lmbench/Makefile
index 9a6835427980..5cd4dd28c2e3 100644
--- a/benchmarks/lmbench/Makefile
+++ b/benchmarks/lmbench/Makefile
@@ -3,7 +3,7 @@
PORTNAME= lmbench
PORTVERSION= 3.0.a9
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= benchmarks
MASTER_SITES= SF/${PORTNAME}/development/${PORTNAME}-3.0-a9 http://thegaul.org/src/
@@ -18,13 +18,7 @@ MAKE_ENV= PATH=${PATH}:${WRKSRC}/scripts
USES= shebangfix perl5 gmake tar:tgz
USE_PERL5= run
SHEBANG_FILES= scripts/getresults
-
-# the bindir for the PLIST is:
-# (note that ./os needs to be run inside the work dir, running it
-# outside will give a different result.)
-#LMBENCH_OS!= cd ${WRKSRC}/scripts && ./os
-#PLIST_SUB= LMBENCH_OS=${LMBENCH_OS}
-PLIST_SUB= "LMBENCH_OS=$$(cd ${WRKSRC}/scripts && ./os)"
+PLIST_SUB= LMBENCH_OS=${ARCH}-${OPSYS:tl}${OSREL}
test: build
@(cd ${WRKSRC}; make results)