aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks
diff options
context:
space:
mode:
authormarius <marius@FreeBSD.org>2018-03-05 03:50:05 +0800
committermarius <marius@FreeBSD.org>2018-03-05 03:50:05 +0800
commit4724a3a444203f640e62f4a9e28124406ac07b7b (patch)
tree84eafa822afb37bcb7233cd4f137370b8abad9cb /benchmarks
parentdbfa92055a4cea4e94bc6d41e65c22f7cb65f870 (diff)
downloadfreebsd-ports-gnome-4724a3a444203f640e62f4a9e28124406ac07b7b.tar.gz
freebsd-ports-gnome-4724a3a444203f640e62f4a9e28124406ac07b7b.tar.zst
freebsd-ports-gnome-4724a3a444203f640e62f4a9e28124406ac07b7b.zip
Given that the netperf project hasn't rolled a release in quite some time,
switch to snapshots directly obtained from the github repository (currently at version 2.7.1). Generally, there aren't that many changes since the 2.7.0 release version of netperf, the most noteworthy changes are in the area of FreeBSD support, though: - FreeBSD-specific code for letting netperf/netserver bind to CPUs, e. g. via the global "-T" option, has been added. - The nettest_bsd back-end now can take advantage of aio(4) via the newly added test-specific "-a" and "-A" options, which in turn allows zero-copy send and receive with e. g. cxgbe(4). Note that this requires the netperf port to be built with its default-on OMNI option disabled, as otherwise the nettest_omni back-end and the migration to it from legacy back-ends (also the upstream default since netperf 2.5.0) will be used instead. Apart from that, some test scripts missing in the published releases but referenced by test scripts already part of e. g. netperf 2.7.0 are now included.
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/netperf/Makefile23
-rw-r--r--benchmarks/netperf/distinfo5
-rw-r--r--benchmarks/netperf/files/patch-configure10
-rw-r--r--benchmarks/netperf/files/patch-doc_examples_find__max__burst.sh11
-rw-r--r--benchmarks/netperf/files/patch-src_dscp.c10
-rw-r--r--benchmarks/netperf/files/patch-src_netcpu__sysctl.c11
-rw-r--r--benchmarks/netperf/pkg-plist2
7 files changed, 35 insertions, 37 deletions
diff --git a/benchmarks/netperf/Makefile b/benchmarks/netperf/Makefile
index aeec9a4e9031..d14c69978eac 100644
--- a/benchmarks/netperf/Makefile
+++ b/benchmarks/netperf/Makefile
@@ -2,19 +2,23 @@
# $FreeBSD$
PORTNAME= netperf
-PORTVERSION= 2.7.0
+PORTVERSION= 2.7.1.p20170921
CATEGORIES= benchmarks ipv6
-MASTER_SITES= http://fossies.org/unix/misc/
MAINTAINER= marius@FreeBSD.org
COMMENT= Network performance benchmarking package
+USE_GITHUB= yes
+GH_ACCOUNT= HewlettPackard
+#GH_TAGNAME= ${PORTNAME}-${PORTVERSION}
+GH_TAGNAME= d566775bf
+
OPTIONS_DEFINE= EXAMPLES EXS HISTOGRAM OMNI SCTP SOCKETS
OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
EXS_DESC= Enable ICSC async socket support
HISTOGRAM_DESC= Enable histogram output
-OMNI_DESC= Enable OMNI tests
+OMNI_DESC= Enable OMNI tests (disable for aio(4) support)
SCTP_DESC= Enable SCTP support
SOCKETS_DESC= Enable Unix Domain socket support
@@ -26,16 +30,17 @@ CONFIGURE_ARGS= --program-prefix="" --program-suffix="" --enable-dirty \
INFO= netperf
-HISTOGRAM_CONFIGURE_ENABLE= histogram
EXS_CONFIGURE_ENABLE= exs
+HISTOGRAM_CONFIGURE_ENABLE= histogram
OMNI_CONFIGURE_ENABLE= omni
-SOCKETS_CONFIGURE_ENABLE= unixdomain
SCTP_CONFIGURE_ENABLE= sctp
+SOCKETS_CONFIGURE_ENABLE= unixdomain
-SCRIPTS= arr_script bloat.sh packet_byte_script runemomni.sh \
- runemomniagg2.sh runemomniaggdemo.sh sctp_stream_script \
- snapshot_script tcp_range_script tcp_rr_script \
- tcp_stream_script udp_rr_script udp_stream_script
+SCRIPTS= arr_script bloat.sh find_max_burst.sh packet_byte_script \
+ remote_hosts runemomni.sh runemomniagg2.sh runemomniaggdemo.sh \
+ sctp_stream_script snapshot_script tcp_range_script \
+ tcp_rr_script tcp_stream_script udp_rr_script \
+ udp_stream_script
post-patch:
.for i in ${SCRIPTS}
diff --git a/benchmarks/netperf/distinfo b/benchmarks/netperf/distinfo
index 2076ab6179e1..1ce89f85daa7 100644
--- a/benchmarks/netperf/distinfo
+++ b/benchmarks/netperf/distinfo
@@ -1,2 +1,3 @@
-SHA256 (netperf-2.7.0.tar.gz) = 9170c4758463bc5342dcdbfc88a40b586fcc9d7ccca048ecbb3b2d49387a28b9
-SIZE (netperf-2.7.0.tar.gz) = 1299801
+TIMESTAMP = 1519739687
+SHA256 (HewlettPackard-netperf-2.7.1.p20170921-d566775bf_GH0.tar.gz) = 66fc216436bdd9dbdb726cc43d6d09a7c5356b4569546fb3dce833ed45ea5b70
+SIZE (HewlettPackard-netperf-2.7.1.p20170921-d566775bf_GH0.tar.gz) = 2010861
diff --git a/benchmarks/netperf/files/patch-configure b/benchmarks/netperf/files/patch-configure
index 31f10b135692..a45924e8e560 100644
--- a/benchmarks/netperf/files/patch-configure
+++ b/benchmarks/netperf/files/patch-configure
@@ -1,19 +1,19 @@
---- configure.orig 2015-07-20 17:30:24 UTC
+--- configure.orig 2017-09-21 17:32:54 UTC
+++ configure
-@@ -6567,7 +6567,7 @@ fi
+@@ -6817,7 +6817,7 @@ fi
done
case "$host" in
-- *-*-freebsd78.*)
+- *-*-freebsd[7-9].* | *-*-freebsd1[0-1].* )
+ *-*-freebsd[7-9].* | *-*-freebsd[1-9][0-9].*)
# FreeBSD 7.x and later SCTP support doesn't need -lsctp.
;;
*)
-@@ -7142,7 +7142,7 @@ ac_cv_lib_kstat=ac_cv_lib_kstat_main
+@@ -7392,7 +7392,7 @@ ac_cv_lib_kstat=ac_cv_lib_kstat_main
enable_cpuutil="kstat - auto"
NETCPU_SOURCE="kstat"
;;
-- *-*-freebsd[4-8].* | *-*-netbsd[1-9].* )
+- *-*-freebsd[4-9].* | *-*-freebsd1[0-1].* | *-*-netbsd[1-9].* )
+ *-*-freebsd[4-9].* | *-*-freebsd[1-9][0-9].* | *-*-netbsd[1-9].* )
use_cpuutil=true
diff --git a/benchmarks/netperf/files/patch-doc_examples_find__max__burst.sh b/benchmarks/netperf/files/patch-doc_examples_find__max__burst.sh
new file mode 100644
index 000000000000..e20308c2c322
--- /dev/null
+++ b/benchmarks/netperf/files/patch-doc_examples_find__max__burst.sh
@@ -0,0 +1,11 @@
+--- doc/examples/find_max_burst.sh.orig 2017-09-21 17:32:54 UTC
++++ doc/examples/find_max_burst.sh
+@@ -6,7 +6,7 @@
+ LAST_TPS=0
+ BURST=1
+ LAST_BURST=0
+-NETPERF=${NETPERF:="netperf"}
++NETPERF="%%PREFIX%%/bin/netperf"
+
+ TMP_TPS=`$NETPERF -t UDP_RR -P 0 -H $1 -- -b $BURST -D -o throughput -e 1 -s 1M -S 1M`
+
diff --git a/benchmarks/netperf/files/patch-src_dscp.c b/benchmarks/netperf/files/patch-src_dscp.c
deleted file mode 100644
index 43f33fc55353..000000000000
--- a/benchmarks/netperf/files/patch-src_dscp.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/dscp.c.orig 2012-10-11 20:42:06 UTC
-+++ src/dscp.c
-@@ -54,6 +54,7 @@ const char * iptos2str(int iptos);
- */
-
- #if HAVE_NETINET_IN_SYSTM_H
-+#include <sys/types.h>
- #include <netinet/in_systm.h>
- #endif
- #if HAVE_NETINET_IP_H
diff --git a/benchmarks/netperf/files/patch-src_netcpu__sysctl.c b/benchmarks/netperf/files/patch-src_netcpu__sysctl.c
deleted file mode 100644
index b9b3c99aa54e..000000000000
--- a/benchmarks/netperf/files/patch-src_netcpu__sysctl.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/netcpu_sysctl.c.orig 2014-06-03 23:37:37 UTC
-+++ src/netcpu_sysctl.c
-@@ -6,6 +6,8 @@ char netcpu_sysctl_id[]="\
- #endif
-
- #include <stdio.h>
-+#include <stdlib.h>
-+#include <string.h>
- #include <unistd.h>
-
- #if HAVE_INTTYPES_H
diff --git a/benchmarks/netperf/pkg-plist b/benchmarks/netperf/pkg-plist
index fd66708063ee..73f44aafa332 100644
--- a/benchmarks/netperf/pkg-plist
+++ b/benchmarks/netperf/pkg-plist
@@ -4,7 +4,9 @@ man/man1/netperf.1.gz
man/man1/netserver.1.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/arr_script
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bloat.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/find_max_burst.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/packet_byte_script
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/remote_hosts
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/runemomni.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/runemomniagg2.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/runemomniaggdemo.sh