aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-07-16 07:11:12 +0800
committeradamw <adamw@FreeBSD.org>2014-07-16 07:11:12 +0800
commit9343eeba7783ac2ce4c8f5c88ab322647d489c19 (patch)
tree37076f8661cc0a667d6e54eab2728ecc665430a0 /benchmarks
parentd5dd4663dfc459a5aa6a241eff9b72f253fbc4e8 (diff)
downloadfreebsd-ports-gnome-9343eeba7783ac2ce4c8f5c88ab322647d489c19.tar.gz
freebsd-ports-gnome-9343eeba7783ac2ce4c8f5c88ab322647d489c19.tar.zst
freebsd-ports-gnome-9343eeba7783ac2ce4c8f5c88ab322647d489c19.zip
Add OPTIONS_DEFINE=DOCS for ports with %%PORTDOCS%% in the plist.
Where possible, correct a few instances where PORTDOCS was being used to flag stuff in EXAMPLESDIR. For some ports, mostly those owned by ruby@, PORTDOCS is applied to pretty much everything whether it's documentation or example.
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/tsung/Makefile2
-rw-r--r--benchmarks/ttcp/Makefile2
2 files changed, 4 insertions, 0 deletions
diff --git a/benchmarks/tsung/Makefile b/benchmarks/tsung/Makefile
index b4a70065d213..dd19f0eaa4ac 100644
--- a/benchmarks/tsung/Makefile
+++ b/benchmarks/tsung/Makefile
@@ -23,6 +23,8 @@ SHEBANG_FILES= src/*.pl.in src/tsung-plotter/tsung/tsung.py
PLIST_SUB= PORTVERSION=${PORTVERSION}
+OPTIONS_DEFINE= DOCS EXAMPLES
+
post-patch:
@${REINPLACE_CMD} -e 's|MAN_DIR = $$(datadir)/man/man1/|MAN_DIR = $$(prefix)/man/man1/| ; \
s|CONFDIR = $$(docdir)/examples|CONFDIR = $$(prefix)/share/examples/tsung|' \
diff --git a/benchmarks/ttcp/Makefile b/benchmarks/ttcp/Makefile
index 84a46747e644..515dbde2f365 100644
--- a/benchmarks/ttcp/Makefile
+++ b/benchmarks/ttcp/Makefile
@@ -21,6 +21,8 @@ LICENSE_TEXT= The license: ${_LICENSE} (${_LICENSE_NAME}) is standard, please re
NO_WRKSUBDIR= yes
DIST_SUBDIR= ${PORTNAME}
+OPTIONS_DEFINE= DOCS
+
post-extract:
${CP} ${DISTDIR}/${DIST_SUBDIR}/ttcp.c ${WRKSRC}
${CP} ${DISTDIR}/${DIST_SUBDIR}/ttcp.1 ${WRKSRC}