aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks
diff options
context:
space:
mode:
authorfenner <fenner@FreeBSD.org>2001-08-02 05:17:12 +0800
committerfenner <fenner@FreeBSD.org>2001-08-02 05:17:12 +0800
commitdcd3d189d90ac1065475dc45205209170b4f83e5 (patch)
tree850a15c9ea388da73f9a97edc7c3e71bcb767a4b /benchmarks
parenta9643a14c0e7164b1d9fc82d357d7212e0106be6 (diff)
downloadfreebsd-ports-gnome-dcd3d189d90ac1065475dc45205209170b4f83e5.tar.gz
freebsd-ports-gnome-dcd3d189d90ac1065475dc45205209170b4f83e5.tar.zst
freebsd-ports-gnome-dcd3d189d90ac1065475dc45205209170b4f83e5.zip
Don't let patch's auto-RCS-checkout behavior interfere with
applying patches by making the files writable before trying to patch them.
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/lmbench/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/benchmarks/lmbench/Makefile b/benchmarks/lmbench/Makefile
index a616f99a0971..cf30f25fed8a 100644
--- a/benchmarks/lmbench/Makefile
+++ b/benchmarks/lmbench/Makefile
@@ -31,6 +31,17 @@ test: build
retest: build
@(cd ${WRKSRC}; make rerun)
+# The distribution comes with unwritable files; patch's magic RCS behavior
+# causes files to be checked out of RCS before being patched. If an $Id$
+# string is in the patch, this behavior causes the string to change to
+# reflect the locker, meaning that the patch will probably fail. Instead,
+# just chmod +w the files.
+PATCHEDFILES= src/Makefile scripts/config-run scripts/getbg
+pre-patch:
+.for f in ${PATCHEDFILES}
+ @${CHMOD} +w ${WRKSRC}/${f}
+.endfor
+
pre-install:
[ -d ${PREFIX}/lib/lmbench ] || ${MKDIR} ${PREFIX}/lib/lmbench