aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-09 05:09:51 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-09 05:09:51 +0800
commitfbadb9909bfe8487ee834afe12f95610ab67c1e9 (patch)
treec5cb1fd9be33d82e7cd39fe251d33df82c5ba988 /benchmarks
parent95fdac9b582feb68e22b6f78829d644538b4da51 (diff)
downloadfreebsd-ports-gnome-fbadb9909bfe8487ee834afe12f95610ab67c1e9.tar.gz
freebsd-ports-gnome-fbadb9909bfe8487ee834afe12f95610ab67c1e9.tar.zst
freebsd-ports-gnome-fbadb9909bfe8487ee834afe12f95610ab67c1e9.zip
Support staging
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/sipp/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/benchmarks/sipp/Makefile b/benchmarks/sipp/Makefile
index 3190a68afeaf..a6bf7f8a6d05 100644
--- a/benchmarks/sipp/Makefile
+++ b/benchmarks/sipp/Makefile
@@ -13,8 +13,7 @@ COMMENT= SIP benchmarking and testing tool
LICENSE= GPLv2
-PLIST_FILES= bin/sipp
-MAN1= sipp.1
+PLIST_FILES= bin/sipp man/man1/sipp.1.gz
USES= gmake
CPP= ${CXX}
@@ -28,7 +27,6 @@ OPENSSL_DESC= OpenSSL support (for digest auth and SIP over TLS)
GSL_DESC= GSL support (for statistical distributed pauses)
PCAPPLAY_DESC= RTP play support
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGSL}
@@ -83,14 +81,14 @@ post-patch:
.endif #defined(WITH_PCAPPLAY)
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${FILESDIR}/sipp.1 ${PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${FILESDIR}/sipp.1 ${STAGEDIR}${PREFIX}/man/man1
.if ${PORT_OPTIONS:MPCAPPLAY}
- ${MKDIR} ${DATADIR}/pcap
+ ${MKDIR} ${STAGEDIR}${DATADIR}/pcap
.for f in ${PCAP_FILES}
- ${INSTALL_DATA} ${WRKSRC}/pcap/${f} ${DATADIR}/pcap/${f}
+ ${INSTALL_DATA} ${WRKSRC}/pcap/${f} ${STAGEDIR}${DATADIR}/pcap/${f}
.endfor
.endif #defined(WITH_PCAPPLAY)