aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks
diff options
context:
space:
mode:
authorpizzamig <pizzamig@FreeBSD.org>2018-02-21 20:33:59 +0800
committerpizzamig <pizzamig@FreeBSD.org>2018-02-21 20:33:59 +0800
commit952089c9e991b9e63c3a38d56f2ccfc2b1a1b89b (patch)
treedb60cec8f175b32f79f2c33d746971b04f6162d5 /benchmarks
parent083c1b1cc50002e7c39177823e388a58d76178da (diff)
downloadfreebsd-ports-gnome-952089c9e991b9e63c3a38d56f2ccfc2b1a1b89b.tar.gz
freebsd-ports-gnome-952089c9e991b9e63c3a38d56f2ccfc2b1a1b89b.tar.zst
freebsd-ports-gnome-952089c9e991b9e63c3a38d56f2ccfc2b1a1b89b.zip
benchmarks/stress-ng: Update to 0.09.16
Include a fix with CLANG < 5.0 Regerate patch
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/stress-ng/Makefile7
-rw-r--r--benchmarks/stress-ng/distinfo6
-rw-r--r--benchmarks/stress-ng/files/patch-Makefile12
3 files changed, 10 insertions, 15 deletions
diff --git a/benchmarks/stress-ng/Makefile b/benchmarks/stress-ng/Makefile
index b5cc1d52812f..9485a359132d 100644
--- a/benchmarks/stress-ng/Makefile
+++ b/benchmarks/stress-ng/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= stress-ng
-PORTVERSION= 0.09.15
+PORTVERSION= 0.09.16
CATEGORIES= benchmarks
MASTER_SITES= http://kernel.ubuntu.com/~cking/tarballs/stress-ng/
@@ -24,11 +24,6 @@ PLIST_FILES= bin/stress-ng man/man1/stress-ng.1.gz
BROKEN= undefined reference to '__atomic_fetch_add_8'
.endif
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1101000 && ${OSVERSION} < 1200000 && ${ARCH} == amd64
-BUILD_DEPENDS+= clang50:devel/llvm50
-CC= clang50
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/stress-ng ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/stress-ng.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
diff --git a/benchmarks/stress-ng/distinfo b/benchmarks/stress-ng/distinfo
index eed9442a1be8..12dcf8e022da 100644
--- a/benchmarks/stress-ng/distinfo
+++ b/benchmarks/stress-ng/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1517934977
-SHA256 (stress-ng-0.09.15.tar.xz) = bc212829c62902080f7f88e7dddf0614deb766faa13d5cacf942074ac0f0d724
-SIZE (stress-ng-0.09.15.tar.xz) = 327208
+TIMESTAMP = 1519123575
+SHA256 (stress-ng-0.09.16.tar.xz) = 062a8d8cda9c00ff760c39ae80937f1a4b8d5b7b02264e81ae2ff8babf44deb4
+SIZE (stress-ng-0.09.16.tar.xz) = 327620
diff --git a/benchmarks/stress-ng/files/patch-Makefile b/benchmarks/stress-ng/files/patch-Makefile
index 0d0ef6e2a6d9..1b397302534a 100644
--- a/benchmarks/stress-ng/files/patch-Makefile
+++ b/benchmarks/stress-ng/files/patch-Makefile
@@ -1,7 +1,7 @@
---- Makefile.orig 2017-05-18 12:29:44 UTC
+--- Makefile.orig 2018-02-15 17:41:52 UTC
+++ Makefile
-@@ -21,7 +21,7 @@ VERSION=0.08.02
- # Codename "harmful hardware harasser"
+@@ -21,7 +21,7 @@ VERSION=0.09.16
+ # Codename "portable pressure producer"
#
-CFLAGS += -Wall -Wextra -DVERSION='"$(VERSION)"' -O2 -std=gnu99
@@ -9,12 +9,12 @@
#
# Pedantic flags
-@@ -786,7 +786,7 @@ stress-cpu.o: stress-cpu.c
- @rm -f test-decimal.c test-decimal.o
+@@ -345,7 +345,7 @@ personality.h:
+ stress-personality.c: personality.h
perf.o: perf.c perf-event.c
- @gcc -E perf-event.c | grep "PERF_COUNT" | sed 's/,/ /' | awk {'print "#define _SNG_" $$1 " (1)"'} > perf-event.h
+ @$(CC) -E perf-event.c | grep "PERF_COUNT" | sed 's/,/ /' | awk {'print "#define _SNG_" $$1 " (1)"'} > perf-event.h
- @echo $(CC) $(CFLAGS) -c -o $@ $<
+ @echo CC $<
@$(CC) $(CFLAGS) -c -o $@ $<