aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-07-05 18:24:13 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-07-05 18:24:13 +0800
commitab52dabf8f1bab83cb2d38f46cf023a50230b9ef (patch)
tree50cd5d18841578c9ee6dae4b0f6c46aaffd6e104 /benchmarks
parent00b8391ba645565f0386aead49d2dbbed18bfc10 (diff)
downloadfreebsd-ports-gnome-ab52dabf8f1bab83cb2d38f46cf023a50230b9ef.tar.gz
freebsd-ports-gnome-ab52dabf8f1bab83cb2d38f46cf023a50230b9ef.tar.zst
freebsd-ports-gnome-ab52dabf8f1bab83cb2d38f46cf023a50230b9ef.zip
- Add LICENSE
- Switch to options helpers
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/webbench/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/benchmarks/webbench/Makefile b/benchmarks/webbench/Makefile
index a7db5be01448..e65016404991 100644
--- a/benchmarks/webbench/Makefile
+++ b/benchmarks/webbench/Makefile
@@ -9,18 +9,23 @@ MASTER_SITES= SUNSITE/apps/www/servers
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple forking web benchmark
-MAKE_ARGS+= CFLAGS="${CPPFLAGS} ${CFLAGS}"
+LICENSE= GPLv2
-PORTDOCS= copyright changelog
+MAKE_ARGS= CFLAGS="${CPPFLAGS} ${CFLAGS}"
+
+PORTDOCS= ChangeLog
PLIST_FILES= bin/webbench \
man/man1/webbench.1.gz
+OPTIONS_DEFINE= DOCS
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/webbench ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/webbench.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/debian/copyright ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/debian/changelog ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>