aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2013-03-08 10:44:53 +0800
committerbeech <beech@FreeBSD.org>2013-03-08 10:44:53 +0800
commitcb92535dbeb9e7c0d80b195d4af39b8483cfbd8d (patch)
treeba71da9b0b6f20c5174ef6faa28b101f1c02004b /benchmarks
parent678811cee64c6e538d46a410b31aa8b30e6f76e2 (diff)
downloadfreebsd-ports-gnome-cb92535dbeb9e7c0d80b195d4af39b8483cfbd8d.tar.gz
freebsd-ports-gnome-cb92535dbeb9e7c0d80b195d4af39b8483cfbd8d.tar.zst
freebsd-ports-gnome-cb92535dbeb9e7c0d80b195d4af39b8483cfbd8d.zip
Flowgrind grinds flows among hosts in your network. It is a tool similar
to iperf, netperf to measure throughput and other metrics for TCP. Flowgrind is split into two components: the flowgrind daemon and the flowgrind controller. Using the controller, flows between any two systems running the flowgrind daemon can be setup (third party tests). At regular intervals during the test the controller collects and displays the measured results from the daemons. It can run multiple flows at once with the same or different settings and individually schedule every one. Test and control connection can optionally be diverted to different interfaces. WWW: http://launchpad.net/flowgrind PR: ports/176728 Submitted by: Lars Eggert <lars@eggert.org>
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/Makefile1
-rw-r--r--benchmarks/flowgrind/Makefile25
-rw-r--r--benchmarks/flowgrind/distinfo2
-rw-r--r--benchmarks/flowgrind/pkg-descr11
-rw-r--r--benchmarks/flowgrind/pkg-plist4
5 files changed, 43 insertions, 0 deletions
diff --git a/benchmarks/Makefile b/benchmarks/Makefile
index a234c325ce68..8b348db02464 100644
--- a/benchmarks/Makefile
+++ b/benchmarks/Makefile
@@ -16,6 +16,7 @@
SUBDIR += filebench
SUBDIR += fio
SUBDIR += flops
+ SUBDIR += flowgrind
SUBDIR += forkbomb
SUBDIR += geekbench
SUBDIR += gtkperf
diff --git a/benchmarks/flowgrind/Makefile b/benchmarks/flowgrind/Makefile
new file mode 100644
index 000000000000..031b66688d7a
--- /dev/null
+++ b/benchmarks/flowgrind/Makefile
@@ -0,0 +1,25 @@
+# Created by: Lars Eggert <lars@eggert.org>
+# $FreeBSD$
+
+PORTNAME= flowgrind
+PORTVERSION= 0.5.9
+CATEGORIES= benchmarks
+MASTER_SITES= http://launchpad.net/flowgrind/trunk/${PORTNAME}-${PORTVERSION}/+download/
+
+MAINTAINER= lars@eggert.org
+COMMENT= Measure throughput and other metrics for TCP
+
+LIB_DEPENDS= xmlrpc++:${PORTSDIR}/net/xmlrpc-c \
+ gsl:${PORTSDIR}/math/gsl
+BUILD_DEPENDS= ${LOCALBASE}/lib/libpcap.so:${PORTSDIR}/net/libpcap
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+FETCH_ARGS= -pRr
+
+MAN1= flowgrind-stop.1 \
+ flowgrind.1 \
+ flowgrindd.1
+
+.include <bsd.port.pre.mk>
+.include <bsd.port.post.mk>
diff --git a/benchmarks/flowgrind/distinfo b/benchmarks/flowgrind/distinfo
new file mode 100644
index 000000000000..e55068ecdc27
--- /dev/null
+++ b/benchmarks/flowgrind/distinfo
@@ -0,0 +1,2 @@
+SHA256 (flowgrind-0.5.9.tar.bz2) = 5a2dda682fc7b9040bc3c7df8f799801769c2c1f294cdce1ee37336f878379af
+SIZE (flowgrind-0.5.9.tar.bz2) = 209124
diff --git a/benchmarks/flowgrind/pkg-descr b/benchmarks/flowgrind/pkg-descr
new file mode 100644
index 000000000000..5f74c32ae22f
--- /dev/null
+++ b/benchmarks/flowgrind/pkg-descr
@@ -0,0 +1,11 @@
+Flowgrind grinds flows among hosts in your network. It is a tool similar
+to iperf, netperf to measure throughput and other metrics for TCP.
+Flowgrind is split into two components: the flowgrind daemon and the
+flowgrind controller. Using the controller, flows between any two systems
+running the flowgrind daemon can be setup (third party tests). At regular
+intervals during the test the controller collects and displays the
+measured results from the daemons. It can run multiple flows at once with
+the same or different settings and individually schedule every one.
+Test and control connection can optionally be diverted to different interfaces.
+
+WWW: http://launchpad.net/flowgrind
diff --git a/benchmarks/flowgrind/pkg-plist b/benchmarks/flowgrind/pkg-plist
new file mode 100644
index 000000000000..46e4b0ceb1a8
--- /dev/null
+++ b/benchmarks/flowgrind/pkg-plist
@@ -0,0 +1,4 @@
+@comment $FreeBSD$
+bin/flowgrind
+bin/flowgrind-stop
+sbin/flowgrindd