aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-10 21:54:26 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-10 21:54:26 +0800
commit591689f7f7301da41e08d95976e1318322254d75 (patch)
tree3a1e73b4128190b7ed7020b2113a1d94d76b0e93 /benchmarks
parent241bc346167b5bfc4beac8d3b3044454cf6b0f87 (diff)
downloadfreebsd-ports-gnome-591689f7f7301da41e08d95976e1318322254d75.tar.gz
freebsd-ports-gnome-591689f7f7301da41e08d95976e1318322254d75.tar.zst
freebsd-ports-gnome-591689f7f7301da41e08d95976e1318322254d75.zip
According to the Porter's Handbook (5.12.2.3.) default options must be added to
OPTIONS_DEFINE. This policy has been implemented only recently that's why we have many ports violating this policy. This patch adds the default options specified in the Porter's Handbook to OPTIONS_DEFINE where they are being used. Ports maintained by gnome@FreeBSD.org, kde@FreeBSD.org and x11@FreeBSD.org have been excluded. Approved by: portmgr (bapt)
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/blogbench/Makefile2
-rw-r--r--benchmarks/bonnie++/Makefile2
-rw-r--r--benchmarks/gtkperf/Makefile2
-rw-r--r--benchmarks/super-smack/Makefile3
4 files changed, 9 insertions, 0 deletions
diff --git a/benchmarks/blogbench/Makefile b/benchmarks/blogbench/Makefile
index c17c1e989781..7b89d9c10222 100644
--- a/benchmarks/blogbench/Makefile
+++ b/benchmarks/blogbench/Makefile
@@ -19,6 +19,8 @@ PORTDOCS= README
NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-install:
diff --git a/benchmarks/bonnie++/Makefile b/benchmarks/bonnie++/Makefile
index ff087318092a..d8523228ae56 100644
--- a/benchmarks/bonnie++/Makefile
+++ b/benchmarks/bonnie++/Makefile
@@ -23,6 +23,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-1.97.1
PORTDOCS= readme.html
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/benchmarks/gtkperf/Makefile b/benchmarks/gtkperf/Makefile
index 61381ebcf1c4..5d136b2b71d0 100644
--- a/benchmarks/gtkperf/Makefile
+++ b/benchmarks/gtkperf/Makefile
@@ -16,6 +16,8 @@ USES= gmake pkgconfig
GNU_CONFIGURE= yes
USE_GNOME= gtk20 gnomeprefix
+OPTIONS_DEFINE= NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/benchmarks/super-smack/Makefile b/benchmarks/super-smack/Makefile
index 6c5d164b2fca..1fcb13c146b8 100644
--- a/benchmarks/super-smack/Makefile
+++ b/benchmarks/super-smack/Makefile
@@ -24,6 +24,9 @@ PGSQL_DESC= Enable PostgreSQL support
MYSQL_DESC= Enable MySQL support
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MMYSQL}