aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks
diff options
context:
space:
mode:
authorjmz <jmz@FreeBSD.org>2006-02-10 05:58:12 +0800
committerjmz <jmz@FreeBSD.org>2006-02-10 05:58:12 +0800
commit9b5abd41ff072e4be4634d1109621235b96f975d (patch)
tree4593b9359465ba0907f3dc924e9a082aa2bb3fac /benchmarks
parent1cafb4c13f3e4b34afca7d0694dbe551d265cdf0 (diff)
downloadfreebsd-ports-gnome-9b5abd41ff072e4be4634d1109621235b96f975d.tar.gz
freebsd-ports-gnome-9b5abd41ff072e4be4634d1109621235b96f975d.tar.zst
freebsd-ports-gnome-9b5abd41ff072e4be4634d1109621235b96f975d.zip
Build fix for 4.x: don't use pthreads
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/iozone/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/benchmarks/iozone/Makefile b/benchmarks/iozone/Makefile
index 25c77e99d604..146c7004f769 100644
--- a/benchmarks/iozone/Makefile
+++ b/benchmarks/iozone/Makefile
@@ -27,10 +27,12 @@ ALL_TARGET=
MAN1= iozone.1
PLIST_FILES= bin/iozone
-OPTIONS= THREADS "Enable threading (uses pthreads)" on
-
.include <bsd.port.pre.mk>
+.if ${OSVERSION} > 500000
+OPTIONS= THREADS "Enable threading (uses pthreads)" on
+.endif
+
.if defined (WITH_THREADS)
CFLAGS+= -pthread
MAKE_ENV= LDFLAGS=-lpthread