aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks
diff options
context:
space:
mode:
authorbrucec <brucec@FreeBSD.org>2013-02-22 23:02:58 +0800
committerbrucec <brucec@FreeBSD.org>2013-02-22 23:02:58 +0800
commitc13fdebf42b4230d0852b64444a73547f7b0bea1 (patch)
tree1fab58fcbe92ab18a11715ad3866630bdb80b2a0 /benchmarks
parent52210da70579c58edbba271c24ceabf3baea216f (diff)
downloadfreebsd-ports-gnome-c13fdebf42b4230d0852b64444a73547f7b0bea1.tar.gz
freebsd-ports-gnome-c13fdebf42b4230d0852b64444a73547f7b0bea1.tar.zst
freebsd-ports-gnome-c13fdebf42b4230d0852b64444a73547f7b0bea1.zip
Move sysutils/fio to benchmarks category.
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/Makefile1
-rw-r--r--benchmarks/fio/Makefile39
-rw-r--r--benchmarks/fio/distinfo2
-rw-r--r--benchmarks/fio/pkg-descr6
-rw-r--r--benchmarks/fio/pkg-plist25
5 files changed, 73 insertions, 0 deletions
diff --git a/benchmarks/Makefile b/benchmarks/Makefile
index bc87ca1843e6..45e40945a0c9 100644
--- a/benchmarks/Makefile
+++ b/benchmarks/Makefile
@@ -14,6 +14,7 @@
SUBDIR += expedite
SUBDIR += fhourstones
SUBDIR += filebench
+ SUBDIR += fio
SUBDIR += flops
SUBDIR += forkbomb
SUBDIR += geekbench
diff --git a/benchmarks/fio/Makefile b/benchmarks/fio/Makefile
new file mode 100644
index 000000000000..71688b84cf18
--- /dev/null
+++ b/benchmarks/fio/Makefile
@@ -0,0 +1,39 @@
+# Created by: luigi@FreeBSD.org
+# $FreeBSD$
+
+PORTNAME= fio
+PORTVERSION= 2.0.14
+CATEGORIES= benchmarks
+MASTER_SITES= http://brick.kernel.dk/snaps/
+
+MAINTAINER= brucec@FreeBSD.org
+COMMENT= FIO - flexible IO tester
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+
+OPTIONS_DEFINE= GNUPLOT
+GNUPLOT_DESC= Support for plotting graphs
+
+MAN1= fio.1 fio_generate_plots.1
+
+.include <bsd.port.options.mk>
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/fio ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/fio_generate_plots ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/fio.1 ${MAN1PREFIX}/man/man1/
+ ${INSTALL_MAN} ${WRKSRC}/fio_generate_plots.1 ${MAN1PREFIX}/man/man1
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
+.endif
+
+.if ${PORT_OPTIONS:MGNUPLOT}
+BUILD_DEPENDS+= ${LOCALBASE}/bin/gnuplot:${PORTSDIR}/math/gnuplot
+.endif
+
+.include <bsd.port.mk>
diff --git a/benchmarks/fio/distinfo b/benchmarks/fio/distinfo
new file mode 100644
index 000000000000..876017d52eec
--- /dev/null
+++ b/benchmarks/fio/distinfo
@@ -0,0 +1,2 @@
+SHA256 (fio-2.0.14.tar.bz2) = 4bf01f1d2baf6d4fa905e5489e446e85e01979c427b2c38e2915e039248044e5
+SIZE (fio-2.0.14.tar.bz2) = 253574
diff --git a/benchmarks/fio/pkg-descr b/benchmarks/fio/pkg-descr
new file mode 100644
index 000000000000..98f4950ff59f
--- /dev/null
+++ b/benchmarks/fio/pkg-descr
@@ -0,0 +1,6 @@
+Fio is an I/O testing tool that will spawn a number of threads or
+processes doing a particular type of I/O action as specified by
+the user. Fio can be driven by a 'job file' describing the I/O
+load one wants to simulate.
+
+WWW: http://git.kernel.dk/?p=fio.git
diff --git a/benchmarks/fio/pkg-plist b/benchmarks/fio/pkg-plist
new file mode 100644
index 000000000000..f2ee9d304283
--- /dev/null
+++ b/benchmarks/fio/pkg-plist
@@ -0,0 +1,25 @@
+bin/fio
+bin/fio_generate_plots
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/1mbs_clients
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/aio-read
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cpuio
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/disk-zone-profile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/e4defrag
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/e4defrag2
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/enospc-pressure
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/falloc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/flow
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fsx
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fusion-aw-sync.ini
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/iometer-file-access-server
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/netio
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/null
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/numa
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rdmaio-client
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rdmaio-server
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssd-steadystate.fio
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssd-test
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/surface-scan
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tiobench-example
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/zipf
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%