aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2012-11-14 07:17:48 +0800
committerjhale <jhale@FreeBSD.org>2012-11-14 07:17:48 +0800
commit7b530b99f55171fb37c1955b67fe778901ecaf82 (patch)
treea163821ce1755b30941ece29a7d0b843d0550f6f /benchmarks
parent9001ecd899b8e06f10f7cbbc1ccd6a3d7b91db9b (diff)
downloadfreebsd-ports-gnome-7b530b99f55171fb37c1955b67fe778901ecaf82.tar.gz
freebsd-ports-gnome-7b530b99f55171fb37c1955b67fe778901ecaf82.tar.zst
freebsd-ports-gnome-7b530b99f55171fb37c1955b67fe778901ecaf82.zip
- Convert to new options framework
- Trim Makefile header While here: - Whitespace alignment - Respect MANPREFIX - Remove STRIP_CMD as this is done by INSTALL_PROGRAM - Merge duplicate post-patch targets into one PR: ports/173548 Submitted by: Edward <is.a.relay@gmail.com> Approved by: maintainer Feature safe: yes
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/iozone/Makefile30
1 files changed, 13 insertions, 17 deletions
diff --git a/benchmarks/iozone/Makefile b/benchmarks/iozone/Makefile
index e5bccfcbbbdd..370840a3873f 100644
--- a/benchmarks/iozone/Makefile
+++ b/benchmarks/iozone/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: iozone
-# Date created: 26 September 1994
-# Whom: jmz
-#
+# Created by: jmz
# $FreeBSD$
-#
PORTNAME= iozone
PORTVERSION= 3.397
@@ -27,29 +23,29 @@ MAKE_JOBS_UNSAFE= yes
MAN1= iozone.1
PLIST_FILES= bin/iozone
-OPTIONS= THREADS "Enable threading (uses pthreads)" on \
- SSH "Use ssh in distributed measurement" on
+OPTIONS_DEFINE= SSH THREADS
+OPTIONS_DEFAULT=SSH THREADS
-.include <bsd.port.pre.mk>
+SSH_DESC= Use ssh in distributed measurement
+THREADS_DESC= Enable threading (uses pthreads)
-.if defined (WITH_THREADS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MTHREADS}
CFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= ${PTHREAD_LIBS}
.else
-CFLAGS+=-DNO_THREADS
+CFLAGS+= -DNO_THREADS
.endif
-.if defined (WITH_SSH)
-post-patch::
+post-patch:
+.if ${PORT_OPTIONS:MSSH}
@${REINPLACE_CMD} -e 's|shell\,\"rsh\"|shell\,\"ssh\"|' ${WRKSRC}/iozone.c
.endif
-
-post-patch::
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/makefile
do-install:
- ${STRIP_CMD} ${WRKSRC}/iozone
${INSTALL_PROGRAM} ${WRKSRC}/iozone ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKDIR}/${DISTNAME}/docs/iozone.1 ${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKDIR}/${DISTNAME}/docs/iozone.1 ${MANPREFIX}/man/man1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>