aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2007-06-15 16:11:40 +0800
committerdelphij <delphij@FreeBSD.org>2007-06-15 16:11:40 +0800
commitac2b8fb975aaadcc1aefd5d77ee03be68c20b9b8 (patch)
tree44e6df3973a50c2c1bd508c324af8b3c8dde68a1 /benchmarks
parentb8d72d30867068134b1162178075eee7b3dea4f2 (diff)
downloadfreebsd-ports-gnome-ac2b8fb975aaadcc1aefd5d77ee03be68c20b9b8.tar.gz
freebsd-ports-gnome-ac2b8fb975aaadcc1aefd5d77ee03be68c20b9b8.tar.zst
freebsd-ports-gnome-ac2b8fb975aaadcc1aefd5d77ee03be68c20b9b8.zip
Add an option to use ssh instead of rsh in distributed measurement.
PR: ports/113048 Submitted by: CHAO Shin <quakelee cn.FreeBSD.org> Approved by: maintainer timeout
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/iozone/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/benchmarks/iozone/Makefile b/benchmarks/iozone/Makefile
index 221ced1a880d..69dbfebb5646 100644
--- a/benchmarks/iozone/Makefile
+++ b/benchmarks/iozone/Makefile
@@ -7,7 +7,7 @@
PORTNAME= iozone
PORTVERSION= 3.283
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= benchmarks
MASTER_SITES= http://www.iozone.org/src/current/
DISTNAME= ${PORTNAME}${PORTVERSION:S/./_/}
@@ -27,7 +27,8 @@ ALL_TARGET=
MAN1= iozone.1
PLIST_FILES= bin/iozone
-OPTIONS= THREADS "Enable threading (uses pthreads)" on
+OPTIONS= THREADS "Enable threading (uses pthreads)" on \
+ SSH "Use ssh in distributed measurement" on
.include <bsd.port.pre.mk>
@@ -38,6 +39,9 @@ MAKE_ENV= LDFLAGS=${PTHREAD_LIBS}
CFLAGS+=-DNO_THREADS
.endif
+post-patch:
+ ${REINPLACE_CMD} -e 's|shell\,\"rsh\"|shell\,\"ssh\"|' ${WRKSRC}/iozone.c
+
do-install:
${STRIP_CMD} ${WRKSRC}/iozone
${INSTALL_PROGRAM} ${WRKSRC}/iozone ${PREFIX}/bin