aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks
diff options
context:
space:
mode:
authorjmd <jmd@FreeBSD.org>2017-06-02 08:20:18 +0800
committerjmd <jmd@FreeBSD.org>2017-06-02 08:20:18 +0800
commit2dd794640d42a35150e41f0bc262a17255b9fa43 (patch)
tree4cd14ce27bccc8b3a7c8fb02f6cdf1e84bba8d97 /benchmarks
parent3a7483b2fc21f662f634cc670b7525de9f1a277c (diff)
downloadfreebsd-ports-gnome-2dd794640d42a35150e41f0bc262a17255b9fa43.tar.gz
freebsd-ports-gnome-2dd794640d42a35150e41f0bc262a17255b9fa43.tar.zst
freebsd-ports-gnome-2dd794640d42a35150e41f0bc262a17255b9fa43.zip
benchmarks/clpeak: This brings clpeak to the latest git revision. FreeBSD patches were upstreamed and it now supports fp16 tests. Changing mail address to my FreeBSD one.
Reviewed by: swills (mentor) Approved by: swills (mentor) Differential Revision: https://reviews.freebsd.org/D10917
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/clpeak/Makefile8
-rw-r--r--benchmarks/clpeak/distinfo5
-rw-r--r--benchmarks/clpeak/files/patch-src_include_common.h31
3 files changed, 6 insertions, 38 deletions
diff --git a/benchmarks/clpeak/Makefile b/benchmarks/clpeak/Makefile
index 18a90749d2eb..52d1101dbcfd 100644
--- a/benchmarks/clpeak/Makefile
+++ b/benchmarks/clpeak/Makefile
@@ -2,12 +2,10 @@
# $FreeBSD$
PORTNAME= clpeak
-PORTVERSION= 1.0
-PORTREVISION= 2
-DISTVERSIONPREFIX= v
+PORTVERSION= 1.0g20170524
CATEGORIES= benchmarks
-MAINTAINER= dieterich@ogolem.org
+MAINTAINER= jmd@FreeBSD.org
COMMENT= Benchmarking tool to measure peak capabilities of opencl devices
LICENSE= PD
@@ -22,7 +20,7 @@ ONLY_FOR_ARCHS_REASON_amd64= only builds and is supported on amd64
USE_GITHUB= yes
GH_ACCOUNT= krrishnarraj
-GH_PROJECT= clpeak
+GH_TAGNAME= 75c8746
USE_LDCONFIG= yes
USE_GL= gl
diff --git a/benchmarks/clpeak/distinfo b/benchmarks/clpeak/distinfo
index 1825942ae634..8e0155a935fa 100644
--- a/benchmarks/clpeak/distinfo
+++ b/benchmarks/clpeak/distinfo
@@ -1,2 +1,3 @@
-SHA256 (krrishnarraj-clpeak-v1.0_GH0.tar.gz) = 97b738c80319807d9b20294f778dfbbe81f83bf903dd3b46619b1a71a067e469
-SIZE (krrishnarraj-clpeak-v1.0_GH0.tar.gz) = 95681
+TIMESTAMP = 1495689208
+SHA256 (krrishnarraj-clpeak-1.0g20170524-75c8746_GH0.tar.gz) = 1e393a04df56777d00baf5e954fca3224fbd2c010580db3e6f28a7182bee05c5
+SIZE (krrishnarraj-clpeak-1.0g20170524-75c8746_GH0.tar.gz) = 201266
diff --git a/benchmarks/clpeak/files/patch-src_include_common.h b/benchmarks/clpeak/files/patch-src_include_common.h
deleted file mode 100644
index 1c6f3651832f..000000000000
--- a/benchmarks/clpeak/files/patch-src_include_common.h
+++ /dev/null
@@ -1,31 +0,0 @@
---- src/include/common.h.orig 2015-11-04 06:03:41 UTC
-+++ src/include/common.h
-@@ -8,13 +8,19 @@
- #include <CL/cl.hpp>
- #endif
-
-+#ifdef __FreeBSD__
-+ #include <sys/types.h>
-+#endif
-+
- #include <stdlib.h>
- #include <chrono>
- #include <string>
-
- #define TAB " "
- #define NEWLINE "\n"
-+#ifndef __FreeBSD__
- #define uint unsigned int
-+#endif
-
- #define MAX(X, Y) \
- (X > Y)? X: Y;
-@@ -41,6 +47,8 @@
- #elif defined(__arm__)
- #define OS_NAME "Linux ARM"
- #endif
-+#elif defined(__FreeBSD__)
-+ #define OS_NAME "FreeBSD"
- #endif
-
-