aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-11-30 23:50:30 +0800
committermat <mat@FreeBSD.org>2017-11-30 23:50:30 +0800
commit32512cab3e8dd90b7cd0525bb5dc98007db431e2 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /benchmarks
parentb4ddc365e88ebdb48627086b02365b74119cf189 (diff)
downloadfreebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.tar.gz
freebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.tar.zst
freebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/py-naarad/Makefile6
-rw-r--r--benchmarks/py-zopkio/Makefile8
2 files changed, 7 insertions, 7 deletions
diff --git a/benchmarks/py-naarad/Makefile b/benchmarks/py-naarad/Makefile
index a880d69eb036..de8920d32a15 100644
--- a/benchmarks/py-naarad/Makefile
+++ b/benchmarks/py-naarad/Makefile
@@ -12,9 +12,9 @@ COMMENT= Framework for performance analysis
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytz>=2013.8,1:devel/py-pytz \
- ${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2 \
- ${PYTHON_PKGNAMEPREFIX}luminol>0:math/py-luminol \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytz>=2013.8,1:devel/py-pytz@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}luminol>0:math/py-luminol@${FLAVOR} \
bash:shells/bash \
gawk:lang/gawk
diff --git a/benchmarks/py-zopkio/Makefile b/benchmarks/py-zopkio/Makefile
index f68ea44e64b0..372e9b1f084c 100644
--- a/benchmarks/py-zopkio/Makefile
+++ b/benchmarks/py-zopkio/Makefile
@@ -12,10 +12,10 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= naarad:benchmarks/py-naarad \
- ${PYTHON_PKGNAMEPREFIX}dateutil>0:devel/py-dateutil \
- ${PYTHON_PKGNAMEPREFIX}kazoo>=1.1:devel/py-kazoo \
- ${PYTHON_PKGNAMEPREFIX}paramiko>=1.10.1:security/py-paramiko \
- ${PYTHON_PKGNAMEPREFIX}junit-xml>0:textproc/py-junit-xml \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>0:devel/py-dateutil@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}kazoo>=1.1:devel/py-kazoo@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}paramiko>=1.10.1:security/py-paramiko@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}junit-xml>0:textproc/py-junit-xml@${FLAVOR} \
USES= python
USE_PYTHON= autoplist concurrent distutils