aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks
diff options
context:
space:
mode:
authorashish <ashish@FreeBSD.org>2010-09-21 22:17:23 +0800
committerashish <ashish@FreeBSD.org>2010-09-21 22:17:23 +0800
commit938f864cb4ea91363254d27c67b9f3d2fa632b54 (patch)
tree50bf72705e8a7d40aea98f139200210fbb5d2094 /benchmarks
parenta13cbf6bca1dcef1c3a0124bcfd639dcb136f3bc (diff)
downloadfreebsd-ports-gnome-938f864cb4ea91363254d27c67b9f3d2fa632b54.tar.gz
freebsd-ports-gnome-938f864cb4ea91363254d27c67b9f3d2fa632b54.tar.zst
freebsd-ports-gnome-938f864cb4ea91363254d27c67b9f3d2fa632b54.zip
NetPerfMeter is a network performance meter for the UDP,
TCP, SCTP and DCCP transport protocols over IPv4 and IPv6. It simultaneously transmits bidirectional flows to an endpoint and measures the resulting flow bandwidths and QoS. The results are written as vector and scalar files. The vector files can e.g. be used to create plots of the results. WWW: http://www.iem.uni-due.de/~dreibh/netperfmeter/ PR: ports/148994 Approved by: tabthorpe (mentor)
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/Makefile1
-rw-r--r--benchmarks/netperfmeter/Makefile36
-rw-r--r--benchmarks/netperfmeter/distinfo3
-rw-r--r--benchmarks/netperfmeter/pkg-descr8
4 files changed, 48 insertions, 0 deletions
diff --git a/benchmarks/Makefile b/benchmarks/Makefile
index 99fdb1aff186..bb7b2aebdd63 100644
--- a/benchmarks/Makefile
+++ b/benchmarks/Makefile
@@ -30,6 +30,7 @@
SUBDIR += nbench
SUBDIR += netio
SUBDIR += netperf
+ SUBDIR += netperfmeter
SUBDIR += netpipe
SUBDIR += nqueens
SUBDIR += nttcp
diff --git a/benchmarks/netperfmeter/Makefile b/benchmarks/netperfmeter/Makefile
new file mode 100644
index 000000000000..5a614ca23035
--- /dev/null
+++ b/benchmarks/netperfmeter/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: netperfmeter
+# Date created: 27 July 2010
+# Whom: Thomas Dreibholz <dreibh@iem.uni-due.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= netperfmeter
+PORTVERSION= 1.0.4
+CATEGORIES= benchmarks
+MASTER_SITES= http://www.iem.uni-due.de/~dreibh/netperfmeter/download/ http://www.exp-math.uni-essen.de/~dreibh/netperfmeter/download/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= dreibh@iem.uni-due.de
+COMMENT= Network Performance Meter
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+PLIST_FILES= bin/netperfmeter
+
+MAN8= netperfmeter.8
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+IGNORE= not supported on systems earlier than 7.x
+.endif
+
+post-install:
+ @${RMDIR} ${DATADIR}
+
+.include <bsd.port.post.mk>
diff --git a/benchmarks/netperfmeter/distinfo b/benchmarks/netperfmeter/distinfo
new file mode 100644
index 000000000000..dbe9019c7aa6
--- /dev/null
+++ b/benchmarks/netperfmeter/distinfo
@@ -0,0 +1,3 @@
+MD5 (netperfmeter-1.0.4.tar.gz) = 7a870d369af6681772014d8fd7afc54c
+SHA256 (netperfmeter-1.0.4.tar.gz) = c6995207fe358a202a3acac08edf4d552ddc2a886de2f5b60436fb9886896f8f
+SIZE (netperfmeter-1.0.4.tar.gz) = 395231
diff --git a/benchmarks/netperfmeter/pkg-descr b/benchmarks/netperfmeter/pkg-descr
new file mode 100644
index 000000000000..8dfd0d734923
--- /dev/null
+++ b/benchmarks/netperfmeter/pkg-descr
@@ -0,0 +1,8 @@
+NetPerfMeter is a network performance meter for the UDP,
+TCP, SCTP and DCCP transport protocols over IPv4 and IPv6.
+It simultaneously transmits bidirectional flows to an endpoint
+and measures the resulting flow bandwidths and QoS. The
+results are written as vector and scalar files. The vector
+files can e.g. be used to create plots of the results.
+
+WWW: http://www.iem.uni-due.de/~dreibh/netperfmeter/