aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-07-28 21:15:41 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-07-28 21:15:41 +0800
commitbe7bfec92c49a2664e27c3eef8322876a93daea3 (patch)
treed414fee5aafabd6705413bff79158e8c703244bc /benchmarks
parent879d6e54f680ab7867f2af5077ac26a3c1ae149e (diff)
downloadfreebsd-ports-gnome-be7bfec92c49a2664e27c3eef8322876a93daea3.tar.gz
freebsd-ports-gnome-be7bfec92c49a2664e27c3eef8322876a93daea3.tar.zst
freebsd-ports-gnome-be7bfec92c49a2664e27c3eef8322876a93daea3.zip
Add p5-Dumbbench 0.111
This module attempts to implement reasonably robust benchmarking with little extra effort and expertise required from the user. That is to say, benchmarking using this module is likely an improvement over time some-command --to --benchmark or use Benchmark qw/timethis/; timethis(1000, 'system("some-command", ...)'); The module currently works similar to the former command line, except (in layman terms) it will run the command many times, estimate the uncertainty of the result and keep iterating until a certain user-defined precision has been reached. Then, it calculates the resulting uncertainty and goes through some pain to discard bad runs and subtract overhead from the timings. The reported timing includes an uncertainty, so that multiple benchmarks can more easily be compared. Please note that Dumbbench works entirely with wallclock time as reported by Time::HiRes' time() function. WWW: https://metacpan.org/release/Dumbbench
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/Makefile1
-rw-r--r--benchmarks/p5-Dumbbench/Makefile29
-rw-r--r--benchmarks/p5-Dumbbench/distinfo3
-rw-r--r--benchmarks/p5-Dumbbench/pkg-descr23
-rw-r--r--benchmarks/p5-Dumbbench/pkg-plist17
5 files changed, 73 insertions, 0 deletions
diff --git a/benchmarks/Makefile b/benchmarks/Makefile
index 54f7ab902879..cf8755814f16 100644
--- a/benchmarks/Makefile
+++ b/benchmarks/Makefile
@@ -51,6 +51,7 @@
SUBDIR += octave-forge-benchmark
SUBDIR += p5-Benchmark-Forking
SUBDIR += p5-Benchmark-Stopwatch
+ SUBDIR += p5-Dumbbench
SUBDIR += pathchirp
SUBDIR += pathload
SUBDIR += pathrate
diff --git a/benchmarks/p5-Dumbbench/Makefile b/benchmarks/p5-Dumbbench/Makefile
new file mode 100644
index 000000000000..140be62744d1
--- /dev/null
+++ b/benchmarks/p5-Dumbbench/Makefile
@@ -0,0 +1,29 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Dumbbench
+PORTVERSION= 0.111
+CATEGORIES= benchmarks perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:BDFOY
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= More reliable benchmarking with the least amount of thinking
+
+LICENSE= ART20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Capture-Tiny>=0:devel/p5-Capture-Tiny \
+ p5-Class-XSAccessor>=1.05:devel/p5-Class-XSAccessor \
+ p5-Devel-CheckOS>=0:devel/p5-Devel-CheckOS \
+ p5-Number-WithError>=1:math/p5-Number-WithError \
+ p5-Params-Util>=0:devel/p5-Params-Util \
+ p5-Statistics-CaseResampling>=0.06:math/p5-Statistics-CaseResampling
+
+NO_ARCH= yes
+USE_PERL5= configure
+USES= perl5
+
+.include <bsd.port.mk>
diff --git a/benchmarks/p5-Dumbbench/distinfo b/benchmarks/p5-Dumbbench/distinfo
new file mode 100644
index 000000000000..ef3e91b089f6
--- /dev/null
+++ b/benchmarks/p5-Dumbbench/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1532715147
+SHA256 (Dumbbench-0.111.tar.gz) = d31d3ca7d672bd928183ccbf29d3275ea594f7d324ae5f49db6182967c5ab2c7
+SIZE (Dumbbench-0.111.tar.gz) = 35481
diff --git a/benchmarks/p5-Dumbbench/pkg-descr b/benchmarks/p5-Dumbbench/pkg-descr
new file mode 100644
index 000000000000..f8d2e53babc9
--- /dev/null
+++ b/benchmarks/p5-Dumbbench/pkg-descr
@@ -0,0 +1,23 @@
+This module attempts to implement reasonably robust benchmarking with little
+extra effort and expertise required from the user. That is to say, benchmarking
+using this module is likely an improvement over
+
+ time some-command --to --benchmark
+
+or
+
+ use Benchmark qw/timethis/;
+ timethis(1000, 'system("some-command", ...)');
+
+The module currently works similar to the former command line, except (in layman
+terms) it will run the command many times, estimate the uncertainty of the
+result and keep iterating until a certain user-defined precision has been
+reached. Then, it calculates the resulting uncertainty and goes through some
+pain to discard bad runs and subtract overhead from the timings. The reported
+timing includes an uncertainty, so that multiple benchmarks can more easily be
+compared.
+
+Please note that Dumbbench works entirely with wallclock time as reported by
+Time::HiRes' time() function.
+
+WWW: https://metacpan.org/release/Dumbbench
diff --git a/benchmarks/p5-Dumbbench/pkg-plist b/benchmarks/p5-Dumbbench/pkg-plist
new file mode 100644
index 000000000000..7ea0cd1cff70
--- /dev/null
+++ b/benchmarks/p5-Dumbbench/pkg-plist
@@ -0,0 +1,17 @@
+bin/dumbbench
+%%SITE_PERL%%/Benchmark/Dumb.pm
+%%SITE_PERL%%/Dumbbench.pm
+%%SITE_PERL%%/Dumbbench/BoxPlot.pm
+%%SITE_PERL%%/Dumbbench/CPUFrequencyPinner.pm
+%%SITE_PERL%%/Dumbbench/Instance.pm
+%%SITE_PERL%%/Dumbbench/Instance/Cmd.pm
+%%SITE_PERL%%/Dumbbench/Instance/PerlEval.pm
+%%SITE_PERL%%/Dumbbench/Instance/PerlSub.pm
+%%SITE_PERL%%/Dumbbench/Result.pm
+%%SITE_PERL%%/Dumbbench/Stats.pm
+%%PERL5_MAN3%%/Benchmark::Dumb.3.gz
+%%PERL5_MAN3%%/Dumbbench.3.gz
+%%PERL5_MAN3%%/Dumbbench::Instance.3.gz
+%%PERL5_MAN3%%/Dumbbench::Instance::Cmd.3.gz
+%%PERL5_MAN3%%/Dumbbench::Instance::PerlEval.3.gz
+%%PERL5_MAN3%%/Dumbbench::Instance::PerlSub.3.gz