aboutsummaryrefslogtreecommitdiffstats
path: root/biology/distribfold/Makefile
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2002-10-20 02:19:50 +0800
committerlioux <lioux@FreeBSD.org>2002-10-20 02:19:50 +0800
commit4e4c9e8032b5c5953985869f8de1649e87c4f8c3 (patch)
tree98f996c695f9eb18be9abbec7dbae3945da65d30 /biology/distribfold/Makefile
parent6a7c8eb509ba715587827ec646a3c40db1046d98 (diff)
downloadfreebsd-ports-gnome-4e4c9e8032b5c5953985869f8de1649e87c4f8c3.tar.gz
freebsd-ports-gnome-4e4c9e8032b5c5953985869f8de1649e87c4f8c3.tar.zst
freebsd-ports-gnome-4e4c9e8032b5c5953985869f8de1649e87c4f8c3.zip
o Update to snapshot 20021015
o Fix an issue with the startup scripts
Diffstat (limited to 'biology/distribfold/Makefile')
-rw-r--r--biology/distribfold/Makefile19
1 files changed, 16 insertions, 3 deletions
diff --git a/biology/distribfold/Makefile b/biology/distribfold/Makefile
index a8b93ba7e881..bc1b051ff021 100644
--- a/biology/distribfold/Makefile
+++ b/biology/distribfold/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= distribfold
-PORTVERSION= 0.1
+PORTVERSION= 0.1.${RELEASE_DATE}
CATEGORIES= misc net
MASTER_SITES= ftp://ftp.mshri.on.ca/pub/distribfold/download/
DISTNAME= distribfold-current-FreeBSD
@@ -32,8 +32,10 @@ DNETFOLD_GROUP=dnetfold
# default number of processors
WITH_NCPU?= 1
+RELEASE_DATE= 20021015
+
post-patch:
- @${REINPLACE_CMD} -E -e 's|%%DESTINATION_DIR%%|${DESTINATION_DIR}|' \
+ @${REINPLACE_CMD} -E -e 's|%%DESTINATION_DIR%%|${DESTINATION_DIR}/cpu0|' \
${WRKSRC}/foldit
pre-install:
@@ -69,7 +71,7 @@ do-install:
# display package message
@${CAT} ${PKGMESSAGE}
-post-install: cook-install-plist
+post-install: cook-install-plist fix-startup-scripts
.include <bsd.port.pre.mk>
@@ -113,4 +115,15 @@ cook-install-plist: generate-plist
.endfor
.endif
+fix-startup-scripts:
+.if ${WITH_NCPU} > 1
+# for every cpu directory
+ @ncpu=`${CAT} ${WRKDIR}/ncpu` ; \
+ for dir in `${FILESDIR}/number_of_dirs.sh $${ncpu}` ; do \
+ ${REINPLACE_CMD} -e "s|cpu0|cpu$${dir}|" \
+ ${DESTINATION_DIR}/cpu$${dir}/foldit ; \
+ ${RM} -f ${DESTINATION_DIR}/cpu$${dir}/foldit.bak ; \
+ done
+.endif
+
.include <bsd.port.post.mk>