aboutsummaryrefslogtreecommitdiffstats
path: root/biology/libgenome/Makefile
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2002-08-18 03:16:55 +0800
committernaddy <naddy@FreeBSD.org>2002-08-18 03:16:55 +0800
commitce69379647b8ac750cbcfc0bff0350ff2ccbba30 (patch)
tree9560ef267c6cf41cc46092497e7805534ea2215d /biology/libgenome/Makefile
parente2f2ef3607633481f857113d4a8a95880984f505 (diff)
downloadfreebsd-ports-gnome-ce69379647b8ac750cbcfc0bff0350ff2ccbba30.tar.gz
freebsd-ports-gnome-ce69379647b8ac750cbcfc0bff0350ff2ccbba30.tar.zst
freebsd-ports-gnome-ce69379647b8ac750cbcfc0bff0350ff2ccbba30.zip
- Support CXXFLAGS properly.
- Do not install .la file. PR: 41732 Submitted by: Ports Fury
Diffstat (limited to 'biology/libgenome/Makefile')
-rw-r--r--biology/libgenome/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/biology/libgenome/Makefile b/biology/libgenome/Makefile
index 3286693eb207..833f646d2de2 100644
--- a/biology/libgenome/Makefile
+++ b/biology/libgenome/Makefile
@@ -8,19 +8,27 @@
PORTNAME= libgenome
PORTVERSION= 0.5.0
+PORTREVISION= 1
CATEGORIES= biology
MASTER_SITES= http://www.libgenome.org/releases/
DISTNAME= libGenome-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
+USE_REINPLACE= yes
USE_LIBTOOL= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
-.if !defined(NOPORTDOCS)
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O3|@CXXFLAGS@|g' ${WRKSRC}/src/Makefile.in
+
post-install:
+.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- ${CP} -R ${WRKSRC}/doc/html/* ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/html/*.css ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/html/*.gif ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/html/*.html ${DOCSDIR}
.endif
.include <bsd.port.mk>