aboutsummaryrefslogtreecommitdiffstats
path: root/biology/molden/Makefile
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2008-11-07 08:33:32 +0800
committerwxs <wxs@FreeBSD.org>2008-11-07 08:33:32 +0800
commit24739739bd4a08e725e5bc43c24934ba101fc332 (patch)
tree0d2caabe634cd2dedc445bc43c1ea9f129658130 /biology/molden/Makefile
parente70c156280b4676148db9ce90d393f6dbf087527 (diff)
downloadfreebsd-ports-gnome-24739739bd4a08e725e5bc43c24934ba101fc332.tar.gz
freebsd-ports-gnome-24739739bd4a08e725e5bc43c24934ba101fc332.tar.zst
freebsd-ports-gnome-24739739bd4a08e725e5bc43c24934ba101fc332.zip
Distfile was re-rolled. The changes were to fix some bugs in the code.
While I'm here, make it respect NOPORTDOCS.
Diffstat (limited to 'biology/molden/Makefile')
-rw-r--r--biology/molden/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/biology/molden/Makefile b/biology/molden/Makefile
index 8f480a9a211e..14a33cc1e6ce 100644
--- a/biology/molden/Makefile
+++ b/biology/molden/Makefile
@@ -22,6 +22,10 @@ USE_FORTRAN= yes
RESTRICTED= free for academic, non profit usage; do not re-distribute source and executable.
MAKEFILE= ${WRKSRC}/makefile
+.if !defined(NOPORTDOCS)
+PORTDOCS= docs/*
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's,malloc.h,stdlib.h,' ${WRKSRC}/xwin.c
@@ -38,12 +42,12 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gmolden ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/surf/surf ${PREFIX}/bin
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/molden
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+.endif
${MKDIR} ${PREFIX}/share/molden/test
${MKDIR} ${PREFIX}/share/molden/utils
- ${INSTALL_DATA} ${WRKSRC}/doc/* ${PREFIX}/share/doc/molden
${INSTALL_DATA} ${WRKSRC}/test/* ${PREFIX}/share/molden/test
${INSTALL_DATA} ${WRKSRC}/utils/* ${PREFIX}/share/molden/utils
-.endif
.include <bsd.port.mk>