aboutsummaryrefslogtreecommitdiffstats
path: root/biology/molden/files
diff options
context:
space:
mode:
authorsperber <sperber@FreeBSD.org>2012-12-01 07:51:49 +0800
committersperber <sperber@FreeBSD.org>2012-12-01 07:51:49 +0800
commit290b0c9649f38efcd751b373e1b0d4df684e7f7f (patch)
treeac9310ef7dc897dc34221003cc72795c8be0d7d7 /biology/molden/files
parent4168fa2eaa9203c86358f38d1fac18494eac1db4 (diff)
downloadfreebsd-ports-gnome-290b0c9649f38efcd751b373e1b0d4df684e7f7f.tar.gz
freebsd-ports-gnome-290b0c9649f38efcd751b373e1b0d4df684e7f7f.tar.zst
freebsd-ports-gnome-290b0c9649f38efcd751b373e1b0d4df684e7f7f.zip
- Update to version 5.0.2
- Add MAKE_JOBS_UNSAFE - Convert to optionsng PR: ports/171970 Submitted by: KATO Tsuguru <tkato432 _at_ yahoo.com> Approved by: beat (mentor) Feature safe: yes
Diffstat (limited to 'biology/molden/files')
-rw-r--r--biology/molden/files/patch-aa59
-rw-r--r--biology/molden/files/patch-ambfor-makefile37
-rw-r--r--biology/molden/files/patch-surf-makefile20
-rw-r--r--biology/molden/files/patch-xwin.c123
4 files changed, 42 insertions, 197 deletions
diff --git a/biology/molden/files/patch-aa b/biology/molden/files/patch-aa
deleted file mode 100644
index fe0bbedbb986..000000000000
--- a/biology/molden/files/patch-aa
+++ /dev/null
@@ -1,59 +0,0 @@
---- makefile.orig 2008-06-24 15:44:16.000000000 +0200
-+++ makefile 2008-11-10 22:53:22.000000000 +0100
-@@ -12,9 +12,19 @@
- #
- # Disregard compiler warnings on rdmolf.f
- #
--CC = cc
-+#CC = cc
- LIBS = -lX11 -lm
--LIBSG = -L/usr/X11R6/lib -lGLU -lGL -lXmu -lX11 -lm
-+LIBSG = -L${LOCALBASE}/lib -lGLU -lGL -lXmu -lX11 -lm
-+
-+###
-+# FreeBSD
-+#CC = gcc
-+CFLAGS += -c -DDOBACK -DHASTIMER -I${LOCALBASE}/include
-+#FC = f77
-+FFLAGS += #-Wno-globals -fno-globals
-+LIBS = -L${LOCALBASE}/lib -lX11 -lm
-+LDR = ${FC}
-+###
-
- # Silicon Graphics
- #CFLAGS = -c -DDOBACK -DHASTIMER -DCOLOR_OFFSET=0.0
-@@ -52,11 +66,11 @@
- # with GCC4.0 or higher replace the line with:
- # 'external gfortran_iargc'
- #
--CFLAGS = -c -I/usr/X11R6/include -DDOBACK -DHASTIMER -DCOLOR_OFFSET=0.0
--FC = g77
--FFLAGS =
--LIBS = -L/usr/X11R6/lib -lX11 -lm
--LDR = g77
-+#CFLAGS = -c -I/usr/X11R6/include -DDOBACK -DHASTIMER -DCOLOR_OFFSET=0.0
-+#FC = g77
-+#FFLAGS =
-+#LIBS = -L/usr/X11R6/lib -lX11 -lm
-+#LDR = g77
- # 64 bit machines:
- #LIBS = -L/usr/X11R6/lib64 -lX11 -lm
- #
-@@ -191,7 +205,7 @@
- # and the full opengl version of molden 'gmolden', (does not need glut)
- # (make gmolden)
- #
--LIBSOGL = -lglut -lGLU -lGL -lXmu -lX11 -lm
-+LIBSOGL = -L${LOCALBASE}/lib -lglut -lGLU -lGL -lXmu -lX11 -lm
- #
- # on linux :
- #
-@@ -227,7 +241,7 @@
- $(MAKE) -C ambfor
-
- surf/surf: surf/*.h surf/*.c
-- $(MAKE) -C surf depend
-+ #$(MAKE) -C surf depend
- $(MAKE) -C surf
-
- # noxwin will not work as long as the old ocglbck calls arent in dummys
diff --git a/biology/molden/files/patch-ambfor-makefile b/biology/molden/files/patch-ambfor-makefile
index f846b79cbd18..4ac7d7be5838 100644
--- a/biology/molden/files/patch-ambfor-makefile
+++ b/biology/molden/files/patch-ambfor-makefile
@@ -1,17 +1,28 @@
---- ambfor/makefile.orig 2008-10-30 10:06:37.000000000 +0100
-+++ ambfor/makefile 2008-10-30 10:07:19.000000000 +0100
-@@ -14,11 +14,11 @@
+--- ambfor/makefile.orig 2011-04-29 20:40:50.000000000 +0900
++++ ambfor/makefile 2012-09-24 02:50:23.000000000 +0900
+@@ -12,12 +12,12 @@
#
- #CC = cc
+ #
--CFLAGS = -c
--FC = g77
-+CFLAGS += -DFREEBSD=1
-+#FC = g77
- FFLAGS = -c -O3 -ffast-math
+-CFLAGS = -c -g
++CFLAGS += -c
+ #FC = g77
+-FC = gfortran
+-FFLAGS = -c -g -ffast-math -funroll-loops -O3
++#FC = gfortran
++#FFLAGS = -c -g -ffast-math -funroll-loops -O3
LIBS = -lm
--LDR = g77
-+LDR = $(FC)
+-LDR = ${FC} -g
++LDR = ${FC}
- OBJS = ambfor.o angle.o bond.o charge.o conn.o enegrd.o getinp.o \
- param.o tors.o vdwlj.o math.o optimise.o wrtout.o
+ OBJS = angle.o bond.o charge.o conn.o enegrd.o getinp.o param.o \
+ tors.o vdwlj.o math.o switch.o wrtout.o pbc.o
+@@ -47,7 +47,7 @@
+ $(LDR) -o ambmd md.o verlet.o qvdw.o allocmd.o $(OBJS) $(LIBS)
+
+ ambfor.o: ambfor.f
+- ${FC} -c -g -ffast-math -funroll-loops -o ambfor.o ambfor.f
++ ${FC} -c ${FFLAGS} -o ambfor.o ambfor.f
+
+ allocmd.o: alloc.c
+ $(CC) $(CFLAGS) -DMD -c alloc.c -o allocmd.o
diff --git a/biology/molden/files/patch-surf-makefile b/biology/molden/files/patch-surf-makefile
index 5107bc4637d9..56b421c1ea4c 100644
--- a/biology/molden/files/patch-surf-makefile
+++ b/biology/molden/files/patch-surf-makefile
@@ -1,5 +1,21 @@
---- surf/Makefile.orig 2008-10-30 10:12:27.000000000 +0100
-+++ surf/Makefile 2008-10-30 10:08:43.000000000 +0100
+--- surf/Makefile.orig 2008-08-26 02:59:06.000000000 +0900
++++ surf/Makefile 2012-09-24 02:45:55.000000000 +0900
+@@ -1,12 +1,12 @@
+ # Compilation flags
+ #CC = cc
+-CC = cc
++#CC = cc
+ INCLUDE = -I.
+ #LINCLUDE = -lcurses -ltermcap -lm
+ LINCLUDE = -lm
+-OPT_CFLAGS = -O2 $(FLAGS) $(INCLUDE)
++#OPT_CFLAGS = -O2 $(FLAGS) $(INCLUDE)
+ #CFLAGS = -g $(FLAGS) $(INCLUDE)
+-CFLAGS = -O2 $(FLAGS) $(INCLUDE)
++#CFLAGS = -O2 $(FLAGS) $(INCLUDE)
+
+ # These are the user object files in the application
+ SRCS = surf.c io.c compute.c dual.c utils.c lp.c chull.c tessel_cases.c \
@@ -63,46 +63,120 @@
# DO NOT DELETE THIS LINE -- make depend depends on it.
diff --git a/biology/molden/files/patch-xwin.c b/biology/molden/files/patch-xwin.c
deleted file mode 100644
index f521bc4e51a5..000000000000
--- a/biology/molden/files/patch-xwin.c
+++ /dev/null
@@ -1,123 +0,0 @@
---- ./xwin.c.orig 2008-11-10 12:27:25.647441620 -0500
-+++ ./xwin.c 2008-11-10 12:29:25.515496080 -0500
-@@ -22,7 +22,7 @@
- #endif
- #if defined(DARWIN) || defined(FREEBSD)
- #else
--#include <malloc.h>
-+#include <stdlib.h>
- #endif
- #endif
-
-@@ -3360,7 +3360,7 @@
- static int *icopth;
- static int *icoptl;
- static int *icoptm;
--static int linkat = 0;
-+static int link_at = 0;
-
- static QBOXSTRU IANZboxes[MAXAT];
- static QBOXSTRU IZboxes[MAXAT][4];
-@@ -17466,7 +17466,7 @@
- if (ioniom == 1) {
- int ism, isl;
-
-- linkat = 0;
-+ link_at = 0;
-
- /* Counting the number of Link atoms between H and lower
- levels*/
-@@ -17479,10 +17479,10 @@
- if (ionij != 0) continue;
- nconn = xyz.iconn[j*(MXCON+1)];
- for (k=1;k<=nconn;k++) {
-- if (xyz.ityp[xyz.iconn[j*(MXCON+1)+k]-1]/10000 > 0) linkat++;
-+ if (xyz.ityp[xyz.iconn[j*(MXCON+1)+k]-1]/10000 > 0) link_at++;
- }
- }
-- linkat += 20000;
-+ link_at += 20000;
- *itotc = *icopth;
- *imult = *ispopth;
- if (CheckChargeMult()) {
-@@ -17503,7 +17503,7 @@
-
- } else if (ioniom == 2) {
-
-- linkat = 0;
-+ link_at = 0;
-
- /* Counting the number of Link atoms between H and
- lower levels*/
-@@ -17513,10 +17513,10 @@
- if(ionij != 0) continue;
- nconn = xyz.iconn[j*(MXCON+1)];
- for (k=1;k<=nconn;k++) {
-- if (xyz.ityp[xyz.iconn[j*(MXCON+1)+k]-1]/10000 > 0) linkat++;
-+ if (xyz.ityp[xyz.iconn[j*(MXCON+1)+k]-1]/10000 > 0) link_at++;
- }
- }
-- linkat += 20000;
-+ link_at += 20000;
- *itotc = *icopth;
- *imult = *ispopth;
- if (CheckChargeMult()) {
-@@ -17528,7 +17528,7 @@
- break;
- */
- }
-- linkat = 0;
-+ link_at = 0;
-
- /* Counting the number of Link atoms between H+M and
- lower levels*/
-@@ -17538,10 +17538,10 @@
- if (ionij == 2) continue;
- nconn = xyz.iconn[j*(MXCON+1)];
- for (k=1;k<=nconn;k++) {
-- if (xyz.ityp[xyz.iconn[j*(MXCON+1)+k]-1]/10000 == 2) linkat++;
-+ if (xyz.ityp[xyz.iconn[j*(MXCON+1)+k]-1]/10000 == 2) link_at++;
- }
- }
-- linkat += 20000;
-+ link_at += 20000;
- *itotc = *icoptm;
- *imult = *ispoptm;
- if (CheckChargeMult()) {
-@@ -17556,7 +17556,7 @@
- icopt = *icoptl+3;
- ispopt = *ispoptl-1;
- }
-- linkat = 0;
-+ link_at = 0;
- *itotc = icopt - 3;
- *imult = ispopt + 1;
- *ito = itopt[jmode] + 1;
-@@ -17808,10 +17808,10 @@
- ionil = 0;
-
- if (ioniom) {
-- ionil = 3 - (linkat / 10000);
-- linkat -= (linkat / 10000) * 10000;
-+ ionil = 3 - (link_at / 10000);
-+ link_at -= (link_at / 10000) * 10000;
- } else {
-- linkat = 0;
-+ link_at = 0;
- }
-
- if (*zmptr.ihaszm) {
-@@ -17834,10 +17834,10 @@
- }
- }
- /*
-- fprintf(stderr,"ionil %d ne %d itotc %d linkat %d mult %d\n",
-- ionil,ne,*itotc,linkat,*imult);
-+ fprintf(stderr,"ionil %d ne %d itotc %d link_at %d mult %d\n",
-+ ionil,ne,*itotc,link_at,*imult);
- */
-- ne = ne - *itotc + linkat;
-+ ne = ne - *itotc + link_at;
- if (ne % 2 == *imult % 2) return(1);
- return(0);
- }