aboutsummaryrefslogtreecommitdiffstats
path: root/biology/njplot
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2014-06-01 19:26:39 +0800
committerohauer <ohauer@FreeBSD.org>2014-06-01 19:26:39 +0800
commitefa62245796e713096c3941d458c774e982d6ab1 (patch)
tree8aecee6187c1e80bbd36ea6499b47c5258b02f63 /biology/njplot
parentea8f7c476fe6451b7d75150441001ede5bd14c5a (diff)
downloadfreebsd-ports-gnome-efa62245796e713096c3941d458c774e982d6ab1.tar.gz
freebsd-ports-gnome-efa62245796e713096c3941d458c774e982d6ab1.tar.zst
freebsd-ports-gnome-efa62245796e713096c3941d458c774e982d6ab1.zip
- add stage support
- add OPTION for X11 - bump PORTREVISION
Diffstat (limited to 'biology/njplot')
-rw-r--r--biology/njplot/Makefile38
1 files changed, 16 insertions, 22 deletions
diff --git a/biology/njplot/Makefile b/biology/njplot/Makefile
index b69561dc2b1b..f7b679c2b792 100644
--- a/biology/njplot/Makefile
+++ b/biology/njplot/Makefile
@@ -3,14 +3,19 @@
PORTNAME= njplot
PORTVERSION= 2.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= biology
MASTER_SITES= ftp://pbil.univ-lyon1.fr/pub/mol_phylogeny/njplot/archive/
MAINTAINER= mzaki@m.u-tokyo.ac.jp
COMMENT= Phylogenetic tree drawing program capable of interactive manipulation
-.ifndef (WITHOUT_X11)
+OPTIONS_DEFINE= DOCS X11
+OPTIONS_DEFAULT= DOCS X11
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MX11}
BUILD_DEPENDS= ${LOCALBASE}/lib/ncbi/libvibrant.a:${PORTSDIR}/biology/ncbi-toolkit
USE_XORG= x11 xt xmu xp
USES= motif
@@ -19,7 +24,7 @@ USES= motif
MAKEFILE= makefile
BINARIES= newicktops newicktotxt
-.ifndef (WITHOUT_X11)
+.if ${PORT_OPTIONS:MX11}
BINARIES+= njplot unrooted
.endif
.for file in ${BINARIES}
@@ -28,30 +33,19 @@ PLIST_FILES+= bin/${file}
PORTDOCS= njplot.help njplot.html njplot.gif
-MAN1= njplot.1 unrooted.1
-NO_STAGE= yes
-
-OPTIONS_DEFINE= DOCS
-
-.include <bsd.port.options.mk>
+MAN_1= njplot.1 unrooted.1
+PLIST_FILES+= man/man1/njplot.1.gz \
+ man/man1/unrooted.1.gz
-.ifdef (WITHOUT_X11)
+.if !${PORT_OPTIONS:MX11}
post-patch:
${REINPLACE_CMD} -e 's|njplot.*unrooted||' ${WRKSRC}/makefile
.endif
do-install:
-.for file in ${BINARIES}
- ${INSTALL_PROGRAM} ${WRKSRC}/${file} ${PREFIX}/bin
-.endfor
-.for file in ${MAN1}
- ${INSTALL_MAN} ${WRKSRC}/${file} ${PREFIX}/man/man1
-.endfor
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
-.for file in ${PORTDOCS}
- ${INSTALL_MAN} ${WRKSRC}/${file} ${DOCSDIR}
-.endfor
-.endif
+ ${INSTALL_PROGRAM} ${BINARIES:S|^|${WRKSRC}/|} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${MAN_1:S|^|${WRKSRC}/|} ${STAGEDIR}${PREFIX}/man/man1
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>