aboutsummaryrefslogtreecommitdiffstats
path: root/biology/p5-TrimGalore
diff options
context:
space:
mode:
authorjwb <jwb@FreeBSD.org>2017-12-09 21:23:32 +0800
committerjwb <jwb@FreeBSD.org>2017-12-09 21:23:32 +0800
commit69eb1c930bacc61b86feb40b592052d0b7e5882c (patch)
tree787e8f01a0cf448674d567c4465af566b2a8e47c /biology/p5-TrimGalore
parent09c6f9094f9c760773a4c04cface8bae5b89841f (diff)
downloadfreebsd-ports-gnome-69eb1c930bacc61b86feb40b592052d0b7e5882c.tar.gz
freebsd-ports-gnome-69eb1c930bacc61b86feb40b592052d0b7e5882c.tar.zst
freebsd-ports-gnome-69eb1c930bacc61b86feb40b592052d0b7e5882c.zip
[new port] biology/p5-TrimGalore: Wrapper around Cutadapt and FastQC for adapter and quality trimming
Approved by: jrm (mentor) Differential Revision: D13400
Diffstat (limited to 'biology/p5-TrimGalore')
-rw-r--r--biology/p5-TrimGalore/Makefile31
-rw-r--r--biology/p5-TrimGalore/distinfo3
-rw-r--r--biology/p5-TrimGalore/pkg-descr4
-rw-r--r--biology/p5-TrimGalore/pkg-plist8
4 files changed, 46 insertions, 0 deletions
diff --git a/biology/p5-TrimGalore/Makefile b/biology/p5-TrimGalore/Makefile
new file mode 100644
index 000000000000..2121137a66a4
--- /dev/null
+++ b/biology/p5-TrimGalore/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= TrimGalore
+DISTVERSION= 0.4.5
+CATEGORIES= biology perl5
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Wrapper around Cutadapt and FastQC for adapter and quality trimming
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cutadapt>0:biology/py-cutadapt@${PY_FLAVOR} \
+ fastqc>0:biology/fastqc
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+USES= perl5 python:env shebangfix
+SHEBANG_FILES= trim_galore
+USE_PERL5= run
+
+USE_GITHUB= yes
+GH_ACCOUNT= FelixKrueger
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/trim_galore ${STAGEDIR}${PREFIX}/bin
+ cd ${WRKSRC} && ${COPYTREE_SHARE} test_files ${STAGEDIR}${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/biology/p5-TrimGalore/distinfo b/biology/p5-TrimGalore/distinfo
new file mode 100644
index 000000000000..2b718e79b72d
--- /dev/null
+++ b/biology/p5-TrimGalore/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1512570215
+SHA256 (FelixKrueger-TrimGalore-0.4.5_GH0.tar.gz) = a6b97e554944ddc6ecd50e78df486521f17225d415aad84e9911163faafe1f3c
+SIZE (FelixKrueger-TrimGalore-0.4.5_GH0.tar.gz) = 21983909
diff --git a/biology/p5-TrimGalore/pkg-descr b/biology/p5-TrimGalore/pkg-descr
new file mode 100644
index 000000000000..849448684845
--- /dev/null
+++ b/biology/p5-TrimGalore/pkg-descr
@@ -0,0 +1,4 @@
+Wrapper around Cutadapt and FastQC to consistently apply adapter and quality
+trimming to FastQ files, with extra functionality for RRBS data.
+
+WWW: https://github.com/FelixKrueger/TrimGalore
diff --git a/biology/p5-TrimGalore/pkg-plist b/biology/p5-TrimGalore/pkg-plist
new file mode 100644
index 000000000000..a9fa63919c1f
--- /dev/null
+++ b/biology/p5-TrimGalore/pkg-plist
@@ -0,0 +1,8 @@
+bin/trim_galore
+%%DATADIR%%/test_files/4_seqs_with_Ns.fastq.gz
+%%DATADIR%%/test_files/colorspace_file.fastq
+%%DATADIR%%/test_files/empty_file.fastq
+%%DATADIR%%/test_files/illumina_100K.fastq.gz
+%%DATADIR%%/test_files/nextera_100K.fastq.gz
+%%DATADIR%%/test_files/smallRNA_100K.fastq.gz
+%%DATADIR%%/test_files/truncated.fq.gz