aboutsummaryrefslogtreecommitdiffstats
path: root/biology/p5-bioperl/Makefile
diff options
context:
space:
mode:
authorwjv <wjv@FreeBSD.org>2001-08-13 18:26:44 +0800
committerwjv <wjv@FreeBSD.org>2001-08-13 18:26:44 +0800
commit305e89bc453303989eaf2f1ea471787e43f9b413 (patch)
tree598ed2b7104e056de772b3ec4239a29245cfaf96 /biology/p5-bioperl/Makefile
parentd3b4a164e364636e2fcf2fd07ab4fa166b39dc87 (diff)
downloadfreebsd-ports-gnome-305e89bc453303989eaf2f1ea471787e43f9b413.tar.gz
freebsd-ports-gnome-305e89bc453303989eaf2f1ea471787e43f9b413.tar.zst
freebsd-ports-gnome-305e89bc453303989eaf2f1ea471787e43f9b413.zip
- Properly list run-time dependencies in RUN_DEPENDS in Makefile.
- Deploy %%PERL_VER%% and %%PERL_ARCH%% pragmas consistently throughout pkg-plist. (Ouch, that was embarrassing.) - Bump PORTREVISION due to the above. - Update my email address and the project's URL in pkg-descr.
Diffstat (limited to 'biology/p5-bioperl/Makefile')
-rw-r--r--biology/p5-bioperl/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/biology/p5-bioperl/Makefile b/biology/p5-bioperl/Makefile
index 650a028aa69c..256e1b4acc5a 100644
--- a/biology/p5-bioperl/Makefile
+++ b/biology/p5-bioperl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bioperl
PORTVERSION= 0.7.1
+PORTREVISION= 1
CATEGORIES= biology perl5
MASTER_SITES= ftp://bioperl.org/pub/DIST/ \
http://bioperl.org/Core/Latest/ \
@@ -17,6 +18,8 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= wjv@FreeBSD.org
+# These are all run-time dependencies, but listing them in ${BUILD_DEPENDS}
+# prevents a flood of build-time warnings.
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Ace.pm:${PORTSDIR}/biology/p5-AcePerl \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
@@ -27,6 +30,7 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Ace.pm:
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/XML/Node.pm:${PORTSDIR}/textproc/p5-XML-Node \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/XML/Parser/PerlSAX.pm:${PORTSDIR}/textproc/p5-libxml \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/XML/Writer.pm:${PORTSDIR}/textproc/p5-XML-Writer
+RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= YES
@@ -44,9 +48,11 @@ EXT_WRKSRC= ${WRKDIR}/bioperl-ext-06/Bio/Ext/Align
.if defined(WITH_CORBA_CLIENT)
BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/CORBA/ORBit.pm:${PORTSDIR}/devel/p5-ORBit
+RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/CORBA/ORBit.pm:${PORTSDIR}/devel/p5-ORBit
.endif
.if defined(WITH_CORBA_SERVER)
BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/CORBA/ORBit.pm:${PORTSDIR}/devel/p5-ORBit
+RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/CORBA/ORBit.pm:${PORTSDIR}/devel/p5-ORBit
.endif
.if defined(WITH_GUI)
RUN_DEPENDS+= ptksh:${PORTSDIR}/x11-toolkits/p5-Tk