aboutsummaryrefslogtreecommitdiffstats
path: root/biology/paml/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>2000-07-10 11:21:05 +0800
committersteve <steve@FreeBSD.org>2000-07-10 11:21:05 +0800
commit9946c57002921ea136b21da5688bcbe17225ffa1 (patch)
tree218e6e77bf3eb738cebd7c72b3ee801679cff5f9 /biology/paml/Makefile
parente370be5520e25930901f6e279f1e35b8c8cf289f (diff)
downloadfreebsd-ports-gnome-9946c57002921ea136b21da5688bcbe17225ffa1.tar.gz
freebsd-ports-gnome-9946c57002921ea136b21da5688bcbe17225ffa1.tar.zst
freebsd-ports-gnome-9946c57002921ea136b21da5688bcbe17225ffa1.zip
Add paml version 3.01.
A set of utilities for performing Phylogenetic Analysis by Maximum Likelihood (PAML). PR: 19753 Submitted by: David A. Bader <dbader@cielo.eece.unm.edu>
Diffstat (limited to 'biology/paml/Makefile')
-rw-r--r--biology/paml/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/biology/paml/Makefile b/biology/paml/Makefile
new file mode 100644
index 000000000000..5b792993ec00
--- /dev/null
+++ b/biology/paml/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: paml
+# Date created: 7 July 2000
+# Whom: dbader@eece.unm.edu
+#
+# $FreeBSD$
+#
+
+PORTNAME= paml
+PORTVERSION= 3.01
+CATEGORIES= biology
+MASTER_SITES= ftp://abacus.gene.ucl.ac.uk/pub/paml/
+DISTNAME= paml3.0a
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= dbader@eece.unm.edu
+
+NO_WRKSUBDIR= yes
+
+BINARIES= baseml basemlg chi2 codeml codemlsites evolver mcmctree \
+ pamp yn00
+
+do-install:
+.for f in ${BINARIES}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/pamlDOC.pdf \
+ ${PREFIX}/share/doc/${PORTNAME}
+.endif
+
+.include <bsd.port.mk>