aboutsummaryrefslogtreecommitdiffstats
path: root/biology/phylip/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>2000-07-10 11:25:48 +0800
committersteve <steve@FreeBSD.org>2000-07-10 11:25:48 +0800
commit2c0288f4bcee516c0426956027fc4a91480d4b6b (patch)
tree309f110addd512f77ea6d90ceaed478a133d86c5 /biology/phylip/Makefile
parent9946c57002921ea136b21da5688bcbe17225ffa1 (diff)
downloadfreebsd-ports-gnome-2c0288f4bcee516c0426956027fc4a91480d4b6b.tar.gz
freebsd-ports-gnome-2c0288f4bcee516c0426956027fc4a91480d4b6b.tar.zst
freebsd-ports-gnome-2c0288f4bcee516c0426956027fc4a91480d4b6b.zip
Adding phylip version 3.5.
This is a FREE package of programs for inferring phylogenies and carrying out certain related tasks. At present it contains 30 programs, which carry out different algorithms on different kinds of data. PR: 19705 Submitted by: David A. Bader <dbader@cielo.eece.unm.edu>
Diffstat (limited to 'biology/phylip/Makefile')
-rw-r--r--biology/phylip/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/biology/phylip/Makefile b/biology/phylip/Makefile
new file mode 100644
index 000000000000..b7ec309be6f0
--- /dev/null
+++ b/biology/phylip/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: phylip
+# Date created: 4 July 2000
+# Whom: dbader@eece.unm.edu
+#
+# $FreeBSD$
+#
+
+PORTNAME= phylip
+PORTVERSION= 3.5
+CATEGORIES= biology
+MASTER_SITES= ftp://evolution.genetics.washington.edu/pub/phylip/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= dbader@eece.unm.edu
+
+NO_WRKSUBDIR= yes
+
+BINARIES= clique consense contml contrast dnacomp dnadist dnainvar \
+ dnaml dnamlk dnamove dnapars dnapenny dolmove dollop \
+ dolpenny drawgram drawtree factor fitch gendist kitsch \
+ mix move neighbor penny protdist protpars restml retree \
+ seqboot
+DOCFILES= README clique.doc consense.doc contchar.doc contml.doc \
+ contrast.doc discrete.doc distance.doc dnacomp.doc dnadist.doc \
+ dnainvar.doc dnaml.doc dnamlk.doc dnamove.doc dnapars.doc \
+ dnapenny.doc dollop.doc dolmove.doc dolpenny.doc draw.doc \
+ drawgram.doc drawtree.doc factor.doc fitch.doc gendist.doc \
+ kitsch.doc main.doc makeinf.doc mix.doc move.doc neighbor.doc \
+ penny.doc protdist.doc protml.doc protpars.doc restml.doc \
+ retree.doc seqboot.doc sequence.doc
+
+do-install:
+.for f in ${BINARIES}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
+.for f in ${DOCFILES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/${PORTNAME}
+.endfor
+.endif
+
+.include <bsd.port.mk>