aboutsummaryrefslogtreecommitdiffstats
path: root/biology/phylip/Makefile
diff options
context:
space:
mode:
authorwjv <wjv@FreeBSD.org>2001-08-22 18:02:27 +0800
committerwjv <wjv@FreeBSD.org>2001-08-22 18:02:27 +0800
commit5efa200417832a46d338679a282b5fcd2f7ea940 (patch)
treeaea1a924ab11baa2af136062e012cd12bfcffc4f /biology/phylip/Makefile
parent3a2a7f777d4ad5f5dfeedefe3eac4775520ccc1f (diff)
downloadfreebsd-ports-gnome-5efa200417832a46d338679a282b5fcd2f7ea940.tar.gz
freebsd-ports-gnome-5efa200417832a46d338679a282b5fcd2f7ea940.tar.zst
freebsd-ports-gnome-5efa200417832a46d338679a282b5fcd2f7ea940.zip
- Update to version 3.6.a2.1 - since the distribution tarball hadn't been
renamed between versions, this port failed checksum. - Apply some whitespace edits and cut pkg-descr down to size to placate portlint. Reported by: Jason Stajich <jason@chg.mc.duke.edu> Approved by: No response from MAINTAINER
Diffstat (limited to 'biology/phylip/Makefile')
-rw-r--r--biology/phylip/Makefile24
1 files changed, 11 insertions, 13 deletions
diff --git a/biology/phylip/Makefile b/biology/phylip/Makefile
index 50bed3da3219..68d49952b5a0 100644
--- a/biology/phylip/Makefile
+++ b/biology/phylip/Makefile
@@ -6,23 +6,22 @@
#
PORTNAME= phylip
-PORTVERSION= 3.6
+PORTVERSION= 3.6.a2.1
CATEGORIES= biology
MASTER_SITES= ftp://evolution.genetics.washington.edu/pub/phylip/phylip36/
DISTNAME= ${PORTNAME}
-WRKSRC= ${WRKDIR}/${DISTNAME}/src
EXTRACT_SUFX= .tar.Z
MAINTAINER= dbader@eece.unm.edu
USE_XLIB= yes
-NO_WRKSUBDIR= yes
+BUILD_WRKSRC= ${WRKSRC}/src
BINARIES= clique consense contml contrast dnacomp dnadist dnainvar \
- dnaml dnamlk dnamove dnapars dnapenny dolmove dollop \
+ dnaml dnamlk dnamove dnapars dnapenny dollop dolmove \
dolpenny drawgram drawtree factor fitch gendist kitsch \
- mix move neighbor pars penny proml protdist protpars \
- restdist restml retree seqboot treedist
+ mix move neighbor pars penny proml promlk protdist \
+ protpars restdist restml retree seqboot treedist
DOCFILES= clique.html consense.html contchar.html contml.html \
contrast.html discrete.html distance.html dnacomp.html \
dnadist.html dnainvar.html dnaml.html dnamlk.html \
@@ -30,19 +29,18 @@ DOCFILES= clique.html consense.html contchar.html contml.html \
dolmove.html dolpenny.html draw.html drawgram.html \
drawtree.html factor.html fitch.html gendist.html \
kitsch.html main.html mix.html move.html neighbor.html \
- pars.html penny.html phylip.gif proml.html protdist.html \
- protpars.html restdist.html restml.html retree.html \
- seqboot.html sequence.html treedist.html
+ pars.html penny.html phylip.gif proml.html promlk.html \
+ protdist.html protpars.html restdist.html restml.html \
+ retree.html seqboot.html sequence.html treedist.html
do-install:
.for f in ${BINARIES}
- ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${f} ${PREFIX}/bin
.endfor
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
+ ${MKDIR} ${DOCSDIR}
.for f in ${DOCFILES}
- ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/doc/${f} \
- ${PREFIX}/share/doc/${PORTNAME}
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/doc/${f} ${DOCSDIR}
.endfor
.endif