aboutsummaryrefslogtreecommitdiffstats
path: root/biology/platon/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1999-05-24 10:12:36 +0800
committersteve <steve@FreeBSD.org>1999-05-24 10:12:36 +0800
commit002e8dead4edcb89fdd73f00f5863ca79eba8291 (patch)
tree4ba93755266e97cf7cdc6dbaf79afa75bad79c0d /biology/platon/Makefile
parentafcbc2070fe584eae6511de284e4baea490d993a (diff)
downloadfreebsd-ports-gnome-002e8dead4edcb89fdd73f00f5863ca79eba8291.tar.gz
freebsd-ports-gnome-002e8dead4edcb89fdd73f00f5863ca79eba8291.tar.zst
freebsd-ports-gnome-002e8dead4edcb89fdd73f00f5863ca79eba8291.zip
Allow this port to be built on -current i386 boxes that have egcs' f77
compiler. Mark it broken for -current Alpha boxes.
Diffstat (limited to 'biology/platon/Makefile')
-rw-r--r--biology/platon/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/biology/platon/Makefile b/biology/platon/Makefile
index 6d3b94b71f37..721f1a7aa83f 100644
--- a/biology/platon/Makefile
+++ b/biology/platon/Makefile
@@ -3,7 +3,7 @@
# Date created: 1999-04-22
# Whom: Ryo MIYAMOTO <rmiya@cc.hirosaki-u.ac.jp>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1999/05/07 06:56:51 taoka Exp $
#
DISTNAME= platon
@@ -24,6 +24,15 @@ TESTDATADIR= ABSORB_EXAMPLE ABSTOMPA_EXAMPLE ABSTOMPA_TEST ADDSYM_EXAMPLE \
ASYM_EXAMPLE DELABS_EXAMPLE MULABS_EXAMPLE PSICOR_EXAMPLE \
SQUEEZE_EXAMPLE
+.if ${MACHINE_ARCH} == "alpha"
+BROKEN= "/usr/libexec/elf/ld: platon.o: .got subsegment exceeds 64K (size 88552)"
+.endif
+
+.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 400004
+MAKE_ENV+= HAVE_G2C=yes
+.endif
+
pre-patch:
(cd ${WRKDIR}/${DISTNAME} && ${GUNZIP_CMD} platon.f.Z)
${CP} ${FILESDIR}/Makefile ${WRKDIR}/${DISTNAME}
@@ -55,4 +64,4 @@ do-install:
${PREFIX}/share/doc/platon/TEST/$${dirs} ; \
done
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>