aboutsummaryrefslogtreecommitdiffstats
path: root/biology/pyfasta/Makefile
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2009-11-18 13:53:17 +0800
committerwen <wen@FreeBSD.org>2009-11-18 13:53:17 +0800
commite2ea4fca903437338abcd5ba15a3d8f1104dbe84 (patch)
treeb8a1055ffb8c5efad6a29f4ce8abcd3fb8c2a855 /biology/pyfasta/Makefile
parent0959efbafde514bccebdf145504369b06d04144a (diff)
downloadfreebsd-ports-gnome-e2ea4fca903437338abcd5ba15a3d8f1104dbe84.tar.gz
freebsd-ports-gnome-e2ea4fca903437338abcd5ba15a3d8f1104dbe84.tar.zst
freebsd-ports-gnome-e2ea4fca903437338abcd5ba15a3d8f1104dbe84.zip
pyfasta is a python module for fast, memory-efficient, pythonic
access to fasta sequence files. WWW: http://bitbucket.org/brentp/biostuff/src/
Diffstat (limited to 'biology/pyfasta/Makefile')
-rw-r--r--biology/pyfasta/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/biology/pyfasta/Makefile b/biology/pyfasta/Makefile
new file mode 100644
index 000000000000..6c819734c88c
--- /dev/null
+++ b/biology/pyfasta/Makefile
@@ -0,0 +1,22 @@
+# Ports collection makefile for: pyfasta
+# Date created: 18 Nov, 2009
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pyfasta
+PORTVERSION= 0.3.1
+CATEGORIES= biology python
+MASTER_SITES= CHEESESHOP
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Fast, memory-efficient, pythonic access to fasta sequence files
+
+BUILD_DEPENDS= ${PYNUMPY}
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+
+.include <bsd.port.mk>