aboutsummaryrefslogtreecommitdiffstats
path: root/biology/tinker/files
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-01-25 01:58:44 +0800
committerijliao <ijliao@FreeBSD.org>2001-01-25 01:58:44 +0800
commit280ec3e7fa1bd61a5d4b9c5802d4fb7835fa16de (patch)
tree8c3437a7c4ea0b7b7eb1db08e84fd4715767753a /biology/tinker/files
parent9905c1ce2834b70acbd3fa8f90266f19f8b0755e (diff)
downloadfreebsd-ports-gnome-280ec3e7fa1bd61a5d4b9c5802d4fb7835fa16de.tar.gz
freebsd-ports-gnome-280ec3e7fa1bd61a5d4b9c5802d4fb7835fa16de.tar.zst
freebsd-ports-gnome-280ec3e7fa1bd61a5d4b9c5802d4fb7835fa16de.zip
update from 3.7 to 3.8
PR: 24371 Submitted by: MAINTAINER
Diffstat (limited to 'biology/tinker/files')
-rw-r--r--biology/tinker/files/patch-aa97
-rw-r--r--biology/tinker/files/patch-ab12
-rw-r--r--biology/tinker/files/patch-ac13
-rw-r--r--biology/tinker/files/patch-ad7
-rw-r--r--biology/tinker/files/patch-ae7
-rw-r--r--biology/tinker/files/patch-af11
-rw-r--r--biology/tinker/files/patch-ag11
-rw-r--r--biology/tinker/files/patch-ah5
-rw-r--r--biology/tinker/files/patch-ai5
-rw-r--r--biology/tinker/files/patch-aj5
-rw-r--r--biology/tinker/files/patch-ak7
-rw-r--r--biology/tinker/files/patch-al7
12 files changed, 99 insertions, 88 deletions
diff --git a/biology/tinker/files/patch-aa b/biology/tinker/files/patch-aa
index 526ce65e518c..0d3f17e2ce38 100644
--- a/biology/tinker/files/patch-aa
+++ b/biology/tinker/files/patch-aa
@@ -1,5 +1,5 @@
---- ../make/Makefile.orig Mon Jul 12 10:56:36 1999
-+++ ../make/Makefile Wed May 31 16:00:31 2000
+--- ../make/Makefile.orig Mon Jan 15 12:39:52 2001
++++ ../make/Makefile Mon Jan 15 15:48:37 2001
@@ -9,8 +9,8 @@
##
## 1. make all Build all the TINKER executables
@@ -24,41 +24,36 @@
####################################################################
## Known Machine Types; Uncomment One of the Following Sections ##
-@@ -45,13 +45,13 @@
- ## Compiler: DEC Fortran 77/90, V4.1
+@@ -87,12 +87,12 @@
+ ## Compiler: GNU g77
##
--F77 = /usr/bin/f77
--RM = /sbin/rm
+-F77 = /usr/bin/g77
-LIBS =
-F77FLAGS = -c
--OPTFLAGS = -fast -tune host
--LIBFLAGS = -rlv
--LINKFLAGS = -fast -non_shared -om -WL,-om_no_inst_sched
-+#F77 = /usr/bin/f77
-+#RM = /sbin/rm
+-OPTFLAGS = -O3 -ffast-math
+-LIBFLAGS = -crusv
+-LINKFLAGS =
++#F77 = /usr/bin/g77
+#LIBS =
+#F77FLAGS = -c
-+#OPTFLAGS = -fast -tune host
-+#LIBFLAGS = -rlv
-+#LINKFLAGS = -fast -non_shared -om -WL,-om_no_inst_sched
++#OPTFLAGS = -O3 -ffast-math
++#LIBFLAGS = -crusv
++#LINKFLAGS =
##
- ## Machine: Silicon Graphics
-@@ -104,6 +104,40 @@
- #diagq.o:
- # ${F77} ${F77FLAGS} -ffast-math diagq.f
+ ## Machine: IntelPC / Linux
+@@ -108,6 +108,35 @@
+ #LIBFLAGS = -crusv
+ #LINKFLAGS =
+##
-+## Machine: IntelPC
-+## CPU Type: Pentium Pro
-+## Oper Sys: FreeBSD 3.0
-+## Compiler: f77(f2c/gcc version 2.7.2.1) || egcs g77
-+##
++## Machine: IntelPC / FreeBSD
++## CPU Type: Intel, AMD, Cyrix
++## Oper Sys: FreeBSD 4.2
++## Compiler: f77 , aka g77
+
+F77 = ${FC}
-+RM = /bin/rm
-+
+.if ${FC}==f77
+.if !defined(HAVE_G2C)
+LIBS = -lU77
@@ -70,32 +65,38 @@
+LINKFLAGS =
+.endif
+.elseif ${FC}==g77
-+LIBS=
++LIBS =
+F77FLAGS = -Wno-globals -fno-globals -c -w
+LINKFLAGS =
+.endif
+
+OPTFLAGS = ${FFLAGS} -ffast-math
+.if ${MACHINE_ARCH} == "i386"
-+OPTFLAGS+= -malign-double
++OPTFLAGS += -malign-double
+.endif
+LIBFLAGS = -rcuv
-+diagq.o:
-+ ${F77} ${F77FLAGS} -ffast-math diagq.f
+
#################################################################
## Should not be Necessary to Change Things Below this Point ##
#################################################################
-@@ -775,6 +809,7 @@
- volume2.o \
- writeout.o \
- xyzatm.o
-+ ranlib libtinker.a
+@@ -486,11 +515,13 @@
+ xyzpdb.x \
+ xyzsybyl.x
+
++.SUFFIXES: .x
++
+ .f.o:
+ ${F77} ${F77FLAGS} ${OPTFLAGS} $*.f
+
+-%.x: %.o libtinker.a
+- ${F77} ${LINKFLAGS} -o $@ $^ ${LIBS}
++.o.x: libtinker.a
++ ${F77} ${LINKFLAGS} -o $@ $< libtinker.a ${LIBS}
+
+ all: ${EXEFILES}
- alchemy.x:
- ${F77} ${LINKFLAGS} -o alchemy.x alchemy.o libtinker.a ${LIBS}
-@@ -868,51 +903,51 @@
- ${F77} ${LINKFLAGS} -o xyzsybyl.x xyzsybyl.o libtinker.a ${LIBS}
+@@ -501,56 +532,56 @@
+ cat *.i *.f > tinker.txt
rename:
- mv alchemy.x $(BINDIR)/alchemy
@@ -104,6 +105,7 @@
- mv archive.x $(BINDIR)/archive
- mv correlate.x $(BINDIR)/correlate
- mv crystal.x $(BINDIR)/crystal
+- mv diffuse.x $(BINDIR)/diffuse
- mv distgeom.x $(BINDIR)/distgeom
- mv document.x $(BINDIR)/document
- mv dynamic.x $(BINDIR)/dynamic
@@ -112,8 +114,10 @@
- mv intxyz.x $(BINDIR)/intxyz
- mv minimize.x $(BINDIR)/minimize
- mv minirot.x $(BINDIR)/minirot
+- mv minrigid.x $(BINDIR)/minrigid
- mv newton.x $(BINDIR)/newton
- mv newtrot.x $(BINDIR)/newtrot
+- mv nucleic.x $(BINDIR)/nucleic
- mv optimize.x $(BINDIR)/optimize
- mv optirot.x $(BINDIR)/optirot
- mv optrigid.x $(BINDIR)/optrigid
@@ -123,10 +127,12 @@
- mv pss.x $(BINDIR)/pss
- mv pssrigid.x $(BINDIR)/pssrigid
- mv pssrot.x $(BINDIR)/pssrot
+- mv radial.x $(BINDIR)/radial
- mv saddle.x $(BINDIR)/saddle
- mv scan.x $(BINDIR)/scan
- mv sniffer.x $(BINDIR)/sniffer
- mv spacefill.x $(BINDIR)/spacefill
+- mv spectrum.x $(BINDIR)/spectrum
- mv superpose.x $(BINDIR)/superpose
- mv sybylxyz.x $(BINDIR)/sybylxyz
- mv testgrad.x $(BINDIR)/testgrad
@@ -149,6 +155,7 @@
+ ${INSTALL_PROGRAM} archive.x $(BINDIR)/archive
+ ${INSTALL_PROGRAM} correlate.x $(BINDIR)/correlate
+ ${INSTALL_PROGRAM} crystal.x $(BINDIR)/crystal
++ ${INSTALL_PROGRAM} diffuse.x $(BINDIR)/diffuse
+ ${INSTALL_PROGRAM} distgeom.x $(BINDIR)/distgeom
+ ${INSTALL_PROGRAM} document.x $(BINDIR)/document
+ ${INSTALL_PROGRAM} dynamic.x $(BINDIR)/dynamic
@@ -157,8 +164,10 @@
+ ${INSTALL_PROGRAM} intxyz.x $(BINDIR)/intxyz
+ ${INSTALL_PROGRAM} minimize.x $(BINDIR)/minimize
+ ${INSTALL_PROGRAM} minirot.x $(BINDIR)/minirot
++ ${INSTALL_PROGRAM} minrigid.x $(BINDIR)/minrigid
+ ${INSTALL_PROGRAM} newton.x $(BINDIR)/newton
+ ${INSTALL_PROGRAM} newtrot.x $(BINDIR)/newtrot
++ ${INSTALL_PROGRAM} nucleic.x $(BINDIR)/nucleic
+ ${INSTALL_PROGRAM} optimize.x $(BINDIR)/optimize
+ ${INSTALL_PROGRAM} optirot.x $(BINDIR)/optirot
+ ${INSTALL_PROGRAM} optrigid.x $(BINDIR)/optrigid
@@ -168,10 +177,12 @@
+ ${INSTALL_PROGRAM} pss.x $(BINDIR)/pss
+ ${INSTALL_PROGRAM} pssrigid.x $(BINDIR)/pssrigid
+ ${INSTALL_PROGRAM} pssrot.x $(BINDIR)/pssrot
++ ${INSTALL_PROGRAM} radial.x $(BINDIR)/radial
+ ${INSTALL_PROGRAM} saddle.x $(BINDIR)/saddle
+ ${INSTALL_PROGRAM} scan.x $(BINDIR)/scan
+ ${INSTALL_PROGRAM} sniffer.x $(BINDIR)/sniffer
+ ${INSTALL_PROGRAM} spacefill.x $(BINDIR)/spacefill
++ ${INSTALL_PROGRAM} spectrum.x $(BINDIR)/spectrum
+ ${INSTALL_PROGRAM} superpose.x $(BINDIR)/superpose
+ ${INSTALL_PROGRAM} sybylxyz.x $(BINDIR)/sybylxyz
+ ${INSTALL_PROGRAM} testgrad.x $(BINDIR)/testgrad
@@ -191,3 +202,13 @@
remove_links:
rm -f $(LINKDIR)/alchemy
+@@ -671,8 +702,8 @@
+ bspline.o \
+ calendar.o \
+ center.o \
+- chkxyz.o \
+ cholesky.o \
++ chkxyz.o \
+ clock.o \
+ cluster.o \
+ column.o \
diff --git a/biology/tinker/files/patch-ab b/biology/tinker/files/patch-ab
deleted file mode 100644
index 5fbcd518580c..000000000000
--- a/biology/tinker/files/patch-ab
+++ /dev/null
@@ -1,12 +0,0 @@
---- ../doc/license.txt.orig Wed Jun 16 13:54:43 1999
-+++ ../doc/license.txt Sat Jun 19 14:19:18 1999
-@@ -1,7 +1,7 @@
-- TINKER ­ Software Tools for Molecular Design
-+ TINKER - Software Tools for Molecular Design
-
- Version 3.7 June 1999
-- Copyright © 1990-1999 Jay William Ponder
-+ Copyright (c) 1990-1999 Jay William Ponder
-
- TINKER is a modular program package for molecular mechanics-
- based potential energy calculations, molecular dynamics
diff --git a/biology/tinker/files/patch-ac b/biology/tinker/files/patch-ac
deleted file mode 100644
index e21d420dce16..000000000000
--- a/biology/tinker/files/patch-ac
+++ /dev/null
@@ -1,13 +0,0 @@
-*** ../doc/summary.txt.orig Fri Aug 28 23:50:17 1998
---- ../doc/summary.txt Fri Aug 28 23:50:33 1998
-***************
-*** 1,4 ****
-! TINKER ­ Software Tools for Molecular Design
-
- Jay Ponder Lab, Dept. of Biochemistry & Molecular
- Biophysics,
---- 1,4 ----
-! TINKER - Software Tools for Molecular Design
-
- Jay Ponder Lab, Dept. of Biochemistry & Molecular
- Biophysics,
diff --git a/biology/tinker/files/patch-ad b/biology/tinker/files/patch-ad
deleted file mode 100644
index 7171c8290043..000000000000
--- a/biology/tinker/files/patch-ad
+++ /dev/null
@@ -1,7 +0,0 @@
-*** ../bench/crambin.run.orig Sat Aug 29 21:54:06 1998
---- ../bench/crambin.run Sat Aug 29 21:54:20 1998
-***************
-*** 1 ****
-! ../bin/timer < crambin.input
---- 1 ----
-! timer < crambin.input
diff --git a/biology/tinker/files/patch-ae b/biology/tinker/files/patch-ae
deleted file mode 100644
index d8d1efdaf941..000000000000
--- a/biology/tinker/files/patch-ae
+++ /dev/null
@@ -1,7 +0,0 @@
-*** ../bench/crystal.run.orig Sat Aug 29 21:56:20 1998
---- ../bench/crystal.run Sat Aug 29 21:56:30 1998
-***************
-*** 1 ****
-! ../bin/timer < crystal.input
---- 1 ----
-! timer < crystal.input
diff --git a/biology/tinker/files/patch-af b/biology/tinker/files/patch-af
deleted file mode 100644
index a1fa92a8963a..000000000000
--- a/biology/tinker/files/patch-af
+++ /dev/null
@@ -1,11 +0,0 @@
-*** ../bench/water.run.orig Sat Aug 29 21:56:44 1998
---- ../bench/water.run Sat Aug 29 21:56:58 1998
-***************
-*** 1,3 ****
- cp water.dyn0 water.dyn
-! time ../bin/dynamic < water.input
- rm water.dyn
---- 1,3 ----
- cp water.dyn0 water.dyn
-! time dynamic < water.input
- rm water.dyn
diff --git a/biology/tinker/files/patch-ag b/biology/tinker/files/patch-ag
new file mode 100644
index 000000000000..a1084876fe7d
--- /dev/null
+++ b/biology/tinker/files/patch-ag
@@ -0,0 +1,11 @@
+--- sizes.i.orig Fri Jan 12 11:43:06 2001
++++ sizes.i Fri Jan 12 11:43:38 2001
+@@ -52,7 +52,7 @@
+ integer maxvar,maxopt,maxhess,maxlight,maxvib,maxgeo,maxcell
+ integer maxring,maxfix,maxbio,maxres,maxamino,maxnuc,maxbnd
+ integer maxang,maxtors,maxpi,maxpib,maxpit
+- parameter (maxatm=10000)
++ parameter (maxatm=2500)
+ parameter (maxval=4)
+ parameter (maxgrp=100)
+ parameter (maxtyp=1000)
diff --git a/biology/tinker/files/patch-ah b/biology/tinker/files/patch-ah
new file mode 100644
index 000000000000..c3f23dd2e057
--- /dev/null
+++ b/biology/tinker/files/patch-ah
@@ -0,0 +1,5 @@
+--- ../bench/bench-1.run.orig Tue Jan 9 14:28:53 2001
++++ ../bench/bench-1.run Tue Jan 9 14:29:19 2001
+@@ -1 +1 @@
+-../bin/timer bench-1 1 y
++timer bench-1 1 y
diff --git a/biology/tinker/files/patch-ai b/biology/tinker/files/patch-ai
new file mode 100644
index 000000000000..643cc82de1ed
--- /dev/null
+++ b/biology/tinker/files/patch-ai
@@ -0,0 +1,5 @@
+--- ../bench/bench-2.run.orig Tue Jan 9 14:29:26 2001
++++ ../bench/bench-2.run Tue Jan 9 14:29:33 2001
+@@ -1 +1 @@
+-../bin/timer bench-2 1 y
++timer bench-2 1 y
diff --git a/biology/tinker/files/patch-aj b/biology/tinker/files/patch-aj
new file mode 100644
index 000000000000..1f36c30fe172
--- /dev/null
+++ b/biology/tinker/files/patch-aj
@@ -0,0 +1,5 @@
+--- ../bench/bench-3.run.orig Tue Jan 9 14:29:40 2001
++++ ../bench/bench-3.run Tue Jan 9 14:29:53 2001
+@@ -1 +1 @@
+-time ../bin/vibrate bench-3 0
++time vibrate bench-3 0
diff --git a/biology/tinker/files/patch-ak b/biology/tinker/files/patch-ak
new file mode 100644
index 000000000000..d0549d42829d
--- /dev/null
+++ b/biology/tinker/files/patch-ak
@@ -0,0 +1,7 @@
+--- ../bench/bench-4.run.orig Tue Jan 9 14:29:59 2001
++++ ../bench/bench-4.run Tue Jan 9 14:30:14 2001
+@@ -1,3 +1,3 @@
+ cp bench-4.dyn0 bench-4.dyn
+-time ../bin/dynamic bench-4 1000 1.0 10.0 2 298.0
++time dynamic bench-4 1000 1.0 10.0 2 298.0
+ rm bench-4.dyn
diff --git a/biology/tinker/files/patch-al b/biology/tinker/files/patch-al
new file mode 100644
index 000000000000..8127254d2daa
--- /dev/null
+++ b/biology/tinker/files/patch-al
@@ -0,0 +1,7 @@
+--- ../bench/bench-5.run.orig Tue Jan 9 14:30:18 2001
++++ ../bench/bench-5.run Tue Jan 9 14:30:29 2001
+@@ -1,3 +1,3 @@
+ cp bench-5.dyn0 bench-5.dyn
+-time ../bin/dynamic bench-5 100 1.0 10.0 2 298.0
++time dynamic bench-5 100 1.0 10.0 2 298.0
+ rm bench-5.dyn