aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authorpat <pat@FreeBSD.org>2002-10-30 06:27:17 +0800
committerpat <pat@FreeBSD.org>2002-10-30 06:27:17 +0800
commita337a3121343a1c64d774c1ffba8983ca8e2b26b (patch)
treee42f6a70620d5fdfba449f5a924db2d4cb386bf1 /biology
parent1032d910a2e5da5c0f9947ff428685b6d0be2084 (diff)
downloadfreebsd-ports-gnome-a337a3121343a1c64d774c1ffba8983ca8e2b26b.tar.gz
freebsd-ports-gnome-a337a3121343a1c64d774c1ffba8983ca8e2b26b.tar.zst
freebsd-ports-gnome-a337a3121343a1c64d774c1ffba8983ca8e2b26b.zip
Add another entry for MASTER_SITES and unbreak with latest version of bison
PR: ports/44711 Submitted by: maintainer
Diffstat (limited to 'biology')
-rw-r--r--biology/nab/Makefile5
-rw-r--r--biology/nab/files/patch-nabgrm.y11
-rw-r--r--biology/nab/files/patch-parser.y10
3 files changed, 25 insertions, 1 deletions
diff --git a/biology/nab/Makefile b/biology/nab/Makefile
index d87e52a8103f..1496ea23f8d9 100644
--- a/biology/nab/Makefile
+++ b/biology/nab/Makefile
@@ -1,12 +1,15 @@
# New ports collection Makefile for: nab
# Date created: Sept. 10, 2000
# Whom: M. L. Dodson <bdodson@scms.utmb.edu>
+#
# $FreeBSD$
+#
PORTNAME= nab
PORTVERSION= 4.4
CATEGORIES= biology
-MASTER_SITES= ftp://ftp.scripps.edu/pub/case/
+MASTER_SITES= ftp://ftp.scripps.edu/pub/case/ \
+ http://www.scripps.edu/case/
MAINTAINER= bdodson@scms.utmb.edu
diff --git a/biology/nab/files/patch-nabgrm.y b/biology/nab/files/patch-nabgrm.y
new file mode 100644
index 000000000000..78ff31d21884
--- /dev/null
+++ b/biology/nab/files/patch-nabgrm.y
@@ -0,0 +1,11 @@
+--- src/nabgrm.y.orig Tue Oct 29 13:04:56 2002
++++ src/nabgrm.y Tue Oct 29 13:40:29 2002
+@@ -244,7 +244,7 @@
+ expr_stmt : expr SYM_SEMICOLON
+ { CG_genmain(); CG_genexpr( $1 );
+ CG_genop( NULL, SYM_SEMICOLON ); } ;
+-if_stmt : if_hdr stmt ;
++if_stmt : if_hdr stmt
+ | if_hdr stmt SYM_ELSE
+ { CG_genrword( SYM_ELSE ); } stmt ;
+ for_stmt : for_hdr stmt ;
diff --git a/biology/nab/files/patch-parser.y b/biology/nab/files/patch-parser.y
new file mode 100644
index 000000000000..bdf23a785552
--- /dev/null
+++ b/biology/nab/files/patch-parser.y
@@ -0,0 +1,10 @@
+--- tleap/parser.y.orig Tue Oct 29 13:46:35 2002
++++ tleap/parser.y Tue Oct 29 13:48:18 2002
+@@ -220,6 +220,7 @@
+ {
+ return;
+ }
++ ;
+
+ line : LENDOFCOMMAND
+ | instruct