aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-11-30 23:50:30 +0800
committermat <mat@FreeBSD.org>2017-11-30 23:50:30 +0800
commit32512cab3e8dd90b7cd0525bb5dc98007db431e2 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /biology
parentb4ddc365e88ebdb48627086b02365b74119cf189 (diff)
downloadfreebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.tar.gz
freebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.tar.zst
freebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Diffstat (limited to 'biology')
-rw-r--r--biology/libsbml/Makefile2
-rw-r--r--biology/py-biom-format/Makefile10
-rw-r--r--biology/py-biopython/Makefile2
-rw-r--r--biology/py-bx-python/Makefile2
-rw-r--r--biology/py-cutadapt/Makefile2
-rw-r--r--biology/py-pysam/Makefile5
-rw-r--r--biology/pycogent/Makefile7
-rw-r--r--biology/pyfasta/Makefile1
-rw-r--r--biology/python-nexus/Makefile1
9 files changed, 15 insertions, 17 deletions
diff --git a/biology/libsbml/Makefile b/biology/libsbml/Makefile
index 6ae00f67c805..4ef28a036795 100644
--- a/biology/libsbml/Makefile
+++ b/biology/libsbml/Makefile
@@ -27,7 +27,7 @@ OPTIONS_SUB= yes
PLIST_SUB+= PORTVERSION=${PORTVERSION}
PYTHON_BUILD_DEPENDS= swig2.0:devel/swig20
-PYTHON_USES= python
+PYTHON_USES= python:2.7
PYTHON_CMAKE_ON= -DWITH_PYTHON:BOOL=ON \
-DPYTHON_INCLUDE_DIR:STRING="${PYTHON_INCLUDEDIR}" \
-DPYTHON_LIBRARY:STRING="${PYTHONBASE}/lib/lib${PYTHON_VERSION}.so" \
diff --git a/biology/py-biom-format/Makefile b/biology/py-biom-format/Makefile
index 03b3d210cc32..0c7c567cdafe 100644
--- a/biology/py-biom-format/Makefile
+++ b/biology/py-biom-format/Makefile
@@ -13,10 +13,10 @@ LICENSE= BSD3CLAUSE
BUILD_DEPENDS= ${PYNUMPY}
RUN_DEPENDS= ${PYNUMPY} \
- ${PYTHON_PKGNAMEPREFIX}h5py>=2.6.0:science/py-h5py \
- ${PYTHON_PKGNAMEPREFIX}click>=6.6:devel/py-click \
- ${PYTHON_PKGNAMEPREFIX}future>=0.15.2:devel/py-future \
- ${PYTHON_PKGNAMEPREFIX}scipy>=0.16.1:science/py-scipy
+ ${PYTHON_PKGNAMEPREFIX}h5py>=2.6.0:science/py-h5py@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}click>=6.6:devel/py-click@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}future>=0.15.2:devel/py-future@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0.16.1:science/py-scipy@${FLAVOR}
USE_GITHUB= yes
GH_ACCOUNT= biocore
@@ -27,7 +27,7 @@ USE_PYTHON= autoplist distutils
.include <bsd.port.pre.mk>
.if ${PYTHON_REL} < 3000
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pyqi>=0.2.0:devel/py-pyqi
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pyqi>=0.2.0:devel/py-pyqi@${FLAVOR}
.endif
post-install:
diff --git a/biology/py-biopython/Makefile b/biology/py-biopython/Makefile
index c893687ef364..edc8c7a1e2ef 100644
--- a/biology/py-biopython/Makefile
+++ b/biology/py-biopython/Makefile
@@ -20,6 +20,6 @@ OPTIONS_DEFINE= REPORTLAB
OPTIONS_DEFAULT= REPORTLAB
REPORTLAB_DESC= PDF support in Bio.Graphics module
-REPORTLAB_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}reportlab1>0:print/py-reportlab1
+REPORTLAB_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}reportlab1>0:print/py-reportlab1@${FLAVOR}
.include <bsd.port.mk>
diff --git a/biology/py-bx-python/Makefile b/biology/py-bx-python/Makefile
index 89ccb9749a3e..0a11dd8824da 100644
--- a/biology/py-bx-python/Makefile
+++ b/biology/py-bx-python/Makefile
@@ -14,7 +14,7 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYNUMPY} \
- ${PYTHON_PKGNAMEPREFIX}python-lzo>0:archivers/py-python-lzo
+ ${PYTHON_PKGNAMEPREFIX}python-lzo>0:archivers/py-python-lzo@${FLAVOR}
RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_GITHUB= yes
diff --git a/biology/py-cutadapt/Makefile b/biology/py-cutadapt/Makefile
index 0d215ac15be5..863a1ee70ab2 100644
--- a/biology/py-cutadapt/Makefile
+++ b/biology/py-cutadapt/Makefile
@@ -12,7 +12,7 @@ COMMENT= Finds and removes adapter sequences, primers, poly-A tails, etc
LICENSE= MIT
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xopen>0:archivers/py-xopen
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xopen>0:archivers/py-xopen@${FLAVOR}
USES= python
USE_PYTHON= distutils
diff --git a/biology/py-pysam/Makefile b/biology/py-pysam/Makefile
index 6bcbc6e2584e..afec069f8422 100644
--- a/biology/py-pysam/Makefile
+++ b/biology/py-pysam/Makefile
@@ -12,11 +12,8 @@ COMMENT= Python module for reading, manipulating and writing genomic data sets
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= cython:lang/cython
-RUN_DEPENDS= cython:lang/cython
-
USES= gmake python
-USE_PYTHON= autoplist distutils
+USE_PYTHON= autoplist distutils cython cython_run
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/pysam/*.so
diff --git a/biology/pycogent/Makefile b/biology/pycogent/Makefile
index f0725592332c..a70e2e31f00c 100644
--- a/biology/pycogent/Makefile
+++ b/biology/pycogent/Makefile
@@ -11,13 +11,12 @@ COMMENT= Toolkit for statistical analysis of biological sequences
LICENSE= GPLv2
BUILD_DEPENDS= ${PYNUMPY} \
- ${LOCALBASE}/bin/cython:lang/cython \
- ${LOCALBASE}/bin/sphinx-build:textproc/py-sphinx \
- ${PYTHON_PKGNAMEPREFIX}sqlalchemy10>=1.0.13:databases/py-sqlalchemy10
+ ${LOCALBASE}/bin/sphinx-build:textproc/py-sphinx@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sqlalchemy10>=1.0.13:databases/py-sqlalchemy10@${FLAVOR}
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= python:-2.7
USE_GITHUB= yes
-USE_PYTHON= distutils autoplist
+USE_PYTHON= distutils autoplist cython
.include <bsd.port.mk>
diff --git a/biology/pyfasta/Makefile b/biology/pyfasta/Makefile
index 2c7d49cd2532..c06752787757 100644
--- a/biology/pyfasta/Makefile
+++ b/biology/pyfasta/Makefile
@@ -6,6 +6,7 @@ PORTVERSION= 0.5.2
PORTREVISION= 1
CATEGORIES= biology python
MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= wen@FreeBSD.org
COMMENT= Fast, memory-efficient, pythonic access to fasta sequence files
diff --git a/biology/python-nexus/Makefile b/biology/python-nexus/Makefile
index c55243d5e23a..bf0cb8d97943 100644
--- a/biology/python-nexus/Makefile
+++ b/biology/python-nexus/Makefile
@@ -5,6 +5,7 @@ PORTNAME= python-nexus
PORTVERSION= 1.53
CATEGORIES= biology python
MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= wen@FreeBSD.org
COMMENT= Generic nexus file format reader for python