aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2008-08-21 14:18:49 +0800
committerrafan <rafan@FreeBSD.org>2008-08-21 14:18:49 +0800
commitc8007265d81e778bec43e1f7b073b196887b3604 (patch)
treea30fd3dc7b50670b88ce6f8cf28e0ccf2b1e599a /biology
parent9f3176cd391ec72812d7f37e93b881faa3648b45 (diff)
downloadfreebsd-ports-gnome-c8007265d81e778bec43e1f7b073b196887b3604.tar.gz
freebsd-ports-gnome-c8007265d81e778bec43e1f7b073b196887b3604.tar.zst
freebsd-ports-gnome-c8007265d81e778bec43e1f7b073b196887b3604.zip
Update CONFIGURE_ARGS for how we pass CONFIGURE_TARGET to configure script.
Specifically, newer autoconf (> 2.13) has different semantic of the configure target. In short, one should use --build=CONFIGURE_TARGET instead of CONFIGURE_TARGET directly. Otherwise, you will get a warning and the old semantic may be removed in later autoconf releases. To workaround this issue, many ports hack the CONFIGURE_TARGET variable so that it contains the ``--build='' prefix. To solve this issue, under the fact that some ports still have configure script generated by the old autoconf, we use runtime detection in the do-configure target so that the proper argument can be used. Changes to Mk/*: - Add runtime detection magic in bsd.port.mk - Remove CONFIGURE_TARGET hack in various bsd.*.mk - USE_GNOME=gnometarget is now an no-op Changes to individual ports, other than removing the CONFIGURE_TARGET hack: = pkg-plist changed (due to the ugly CONFIGURE_TARGET prefix in * executables) - comms/gnuradio - science/abinit - science/elmer-fem - science/elmer-matc - science/elmer-meshgen2d - science/elmerfront - science/elmerpost = use x86_64 as ARCH - devel/g-wrap = other changes - print/magicfilter GNU_CONFIGURE -> HAS_CONFIGURE since it's not generated by autoconf Total # of ports modified: 1,027 Total # of ports affected: ~7,000 (set GNU_CONFIGURE to yes) PR: 126524 (obsoletes 52917) Submitted by: rafan Tested on: two pointyhat 7-amd64 exp runs (by pav) Approved by: portmgr (pav)
Diffstat (limited to 'biology')
-rw-r--r--biology/gmap/Makefile1
-rw-r--r--biology/libgenome/Makefile1
-rw-r--r--biology/treepuzzle/Makefile1
-rw-r--r--biology/xdrawchem/Makefile2
4 files changed, 0 insertions, 5 deletions
diff --git a/biology/gmap/Makefile b/biology/gmap/Makefile
index 8a42bae7adac..36272edea722 100644
--- a/biology/gmap/Makefile
+++ b/biology/gmap/Makefile
@@ -21,6 +21,5 @@ FETCH_BEFORE_ARGS= --no-check-certificate
DISABLE_SIZE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
.include <bsd.port.mk>
diff --git a/biology/libgenome/Makefile b/biology/libgenome/Makefile
index b5046f224067..f27daef37562 100644
--- a/biology/libgenome/Makefile
+++ b/biology/libgenome/Makefile
@@ -19,7 +19,6 @@ COMMENT= Toolkit for developing bioinformatic related software in C++
USE_AUTOTOOLS= libtool:15
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_LDCONFIG= yes
post-patch:
diff --git a/biology/treepuzzle/Makefile b/biology/treepuzzle/Makefile
index f114797909b6..365e42ae21f6 100644
--- a/biology/treepuzzle/Makefile
+++ b/biology/treepuzzle/Makefile
@@ -15,7 +15,6 @@ MAINTAINER= jan.lentfer@web.de
COMMENT= Maximum likelihood phylogeny reconstruction using quartets
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
PLIST_FILES= bin/puzzle
pre-configure:
diff --git a/biology/xdrawchem/Makefile b/biology/xdrawchem/Makefile
index d6421fc38e19..ec6b8f52383e 100644
--- a/biology/xdrawchem/Makefile
+++ b/biology/xdrawchem/Makefile
@@ -20,8 +20,6 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_QT_VER= 3
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-
CONFIGURE_ENV= QTINCDIR="${LOCALBASE}/include" \
QTLIBDIR="${LOCALBASE}/lib" \
LDFLAGS="${LDFLAGS} -lm"