aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commite61d6a701f43e8cec5a4ec8c9641daf5376441de (patch)
tree920c5861867d049fb1f1e03285110561450a4ac1 /biology
parent124c6dcab8f89a37ab971e5ad23a959bfaa97426 (diff)
downloadfreebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.gz
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.zst
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'biology')
-rw-r--r--biology/crux/Makefile1
-rw-r--r--biology/embassy/Makefile6
-rw-r--r--biology/mopac/Makefile5
-rw-r--r--biology/protomol/Makefile2
-rw-r--r--biology/xdrawchem/Makefile4
5 files changed, 8 insertions, 10 deletions
diff --git a/biology/crux/Makefile b/biology/crux/Makefile
index f483a50b21ef..3a464a488e6f 100644
--- a/biology/crux/Makefile
+++ b/biology/crux/Makefile
@@ -27,7 +27,6 @@ OPTIONS= SYS_LINALG "Enable system ATLAS/LAPACK" Off
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
USE_FORTRAN= yes
.if defined(WITH_SYS_LINALG)
CONFIGURE_ARGS+= --enable-sys-linalg
diff --git a/biology/embassy/Makefile b/biology/embassy/Makefile
index 09156c4a5bd6..41d1b14baf4b 100644
--- a/biology/embassy/Makefile
+++ b/biology/embassy/Makefile
@@ -46,8 +46,10 @@ OPTIONS= DOMAINATRIX "Protein domain apps" on \
IPRSCAN "InterPro scan" on \
CBSTOOLS "CBS Tools" on
-CONFIGURE_ENV+= CPPFLAGS="-I${PREFIX}/include -I${LOCALBASE}/include -I${LOCALBASE}/emboss/include" \
- LDFLAGS="-L${PREFIX}/lib -L${LOCALBASE}/lib -L${LOCALBASE}/emboss/lib"
+CPPFLAGS+= -I${PREFIX}/include -I${LOCALBASE}/include -I${LOCALBASE}/emboss/include
+LDFLAGS+= -L${PREFIX}/lib -L${LOCALBASE}/lib -L${LOCALBASE}/emboss/lib
+
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
EMBASSY_WRKDIR= ${WRKSRC}/EMBASSY
DOMAINATRIX_VERSION= 0.1.0
diff --git a/biology/mopac/Makefile b/biology/mopac/Makefile
index b51e1710f55c..20eb7487a319 100644
--- a/biology/mopac/Makefile
+++ b/biology/mopac/Makefile
@@ -22,12 +22,11 @@ USE_GMAKE= yes
USE_AUTOTOOLS= aclocal automake autoconf libtool
ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
AUTOMAKE_ARGS= --add-missing --copy
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
MOPAC_SUBVERSION= 1.11
diff --git a/biology/protomol/Makefile b/biology/protomol/Makefile
index 102dd98a43e8..3fc6b7680a23 100644
--- a/biology/protomol/Makefile
+++ b/biology/protomol/Makefile
@@ -27,8 +27,6 @@ CONFIGURE_ARGS+= --without-irix_mipspro_mpi
CPPFLAGS+= -I${LOCALBASE}/include
CXXFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" CXXFLAGS="${CXXFLAGS}"
-
WRKSRC= ${WRKDIR}/${PORTNAME}
OPTIONS= GLUT "Use glut" on
diff --git a/biology/xdrawchem/Makefile b/biology/xdrawchem/Makefile
index e95f483367cb..7743131b468e 100644
--- a/biology/xdrawchem/Makefile
+++ b/biology/xdrawchem/Makefile
@@ -21,8 +21,8 @@ USE_GMAKE= yes
USE_QT_VER= 3
CONFIGURE_ENV= QTINCDIR="${LOCALBASE}/include" \
- QTLIBDIR="${LOCALBASE}/lib" \
- LDFLAGS="${LDFLAGS} -lm"
+ QTLIBDIR="${LOCALBASE}/lib"
+LDFLAGS+= -lm
MAKE_ARGS+= LDFLAGS+="-lqt-mt ${PTHREAD_LIBS}"