aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-05-27 04:02:44 +0800
committerlinimon <linimon@FreeBSD.org>2017-05-27 04:02:44 +0800
commitf165f7743e2cbd42b86a4c6643b7648b0056c167 (patch)
tree0cde4b8b45b7e4393f92305c47df693c2ef646bd /biology
parent2e8e012fe9faa77f49a5d468d23272c102a68d1d (diff)
downloadfreebsd-ports-gnome-f165f7743e2cbd42b86a4c6643b7648b0056c167.tar.gz
freebsd-ports-gnome-f165f7743e2cbd42b86a4c6643b7648b0056c167.tar.zst
freebsd-ports-gnome-f165f7743e2cbd42b86a4c6643b7648b0056c167.zip
Mark some ports failing on armv6, for errors classified as "???".
While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'biology')
-rw-r--r--biology/bwa/Makefile7
-rw-r--r--biology/crux/Makefile2
2 files changed, 6 insertions, 3 deletions
diff --git a/biology/bwa/Makefile b/biology/bwa/Makefile
index 163cc1ce9e03..5bd5cca03c82 100644
--- a/biology/bwa/Makefile
+++ b/biology/bwa/Makefile
@@ -11,8 +11,11 @@ COMMENT= Burrows-Wheeler sequence aligner
LICENSE= GPLv3
-BROKEN_aarch64= fails to compile: error: invalid conversion between vector type and integer type
-BROKEN_powerpc64= fails to compile: ksw.c: error: emmintrin.h: No such file or directory
+BROKEN_aarch64= fails to compile: invalid conversion between vector type and integer type
+BROKEN_armv6= fails to compile: invalid conversion between vector type and integer type
+BROKEN_mips= fails to compile: cc1: unrecognized command line option "-msse2"
+BROKEN_mips64= fails to compile: cc1: unrecognized command line option "-msse2"
+BROKEN_powerpc64= fails to compile: ksw.c: emmintrin.h: No such file or directory
USES= perl5 shebangfix tar:bzip2
SHEBANG_FILES= qualfa2fq.pl xa2multi.pl
diff --git a/biology/crux/Makefile b/biology/crux/Makefile
index 0e33f688b500..86b1fb5860e8 100644
--- a/biology/crux/Makefile
+++ b/biology/crux/Makefile
@@ -14,7 +14,7 @@ LICENSE= BSD2CLAUSE BSD3CLAUSE
LICENSE_COMB= multi
BROKEN_aarch64= Fails to link: ImportError: /lib/libgcc_s.so.1: version GCC_4.5.0 required by /usr/local/lib/gcc5/libgfortran.so.3 not found
-BROKEN_armv64= Fails to link: ImportError: /usr/local/lib/gcc49/libgfortran.so.3: Undefined symbol "__aeabi_ldivmod"
+BROKEN_armv6= Fails to link: ImportError: /usr/local/lib/gcc49/libgfortran.so.3: Undefined symbol "__aeabi_ldivmod"
USES= fortran gmake python tar:bzip2
USE_CSTD= gnu99