aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-08-18 17:31:58 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-08-18 17:31:58 +0800
commitb5db3d10589db818208441d330491eb1769a219a (patch)
treecfbb77c425ef9c145ce8495bad30d3529fc52149 /biology
parent431c114e9a87fd7d44e8eac15c057fdb70d6e77e (diff)
downloadfreebsd-ports-gnome-b5db3d10589db818208441d330491eb1769a219a.tar.gz
freebsd-ports-gnome-b5db3d10589db818208441d330491eb1769a219a.tar.zst
freebsd-ports-gnome-b5db3d10589db818208441d330491eb1769a219a.zip
- Switch to options helpers
- Regenerate patches with `make makepatch` - Mark WXGTK option broken: does not build: src/convErr/gc_errhandling.cpp:75:12: error: cannot initialize return object of type 'const char *' with an rvalue of type 'const wxChar *' (aka 'const wchar_t *')
Diffstat (limited to 'biology')
-rw-r--r--biology/lamarc/Makefile17
-rw-r--r--biology/lamarc/files/patch-src_control_defaults.h (renamed from biology/lamarc/files/patch-src__control__defaults.h)2
-rw-r--r--biology/lamarc/files/patch-src_tools_stringx.h (renamed from biology/lamarc/files/patch-src-tools_stringx.h)8
3 files changed, 11 insertions, 16 deletions
diff --git a/biology/lamarc/Makefile b/biology/lamarc/Makefile
index 2e5e3b0b3c1c..f467adfed096 100644
--- a/biology/lamarc/Makefile
+++ b/biology/lamarc/Makefile
@@ -14,8 +14,6 @@ COMMENT= Package of programs for computing population parameters
LICENSE= APACHE20
-OPTIONS_DEFINE= WXGTK DOCS
-
WRKSRC= ${WRKDIR}/${DISTNAME:S,${DISTVERSIONSUFFIX},,}
GNU_CONFIGURE= yes
@@ -23,16 +21,13 @@ GNU_CONFIGURE= yes
PORTDOCS= *
PLIST_FILES= bin/${PORTNAME}
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= WXGTK DOCS
-.if ${PORT_OPTIONS:MWXGTK}
-USE_WX= 2.8
-WX_CONF_ARGS= absolute
-WX_UNICODE= yes
-PLIST_FILES+= bin/lam_conv
-.else
-CONFIGURE_ARGS+= --disable-converter
-.endif
+WXGTK_USE= WX=2.8
+WXGTK_VARS= WX_CONF_ARGS=absolute
+WXGTK_PLIST_FILES= bin/lam_conv
+WXGTK_CONFIGURE_OFF= --disable-converter
+WXGTK_BROKEN= does not build
post-patch:
@${REINPLACE_CMD} -e \
diff --git a/biology/lamarc/files/patch-src__control__defaults.h b/biology/lamarc/files/patch-src_control_defaults.h
index 0bf8cd156e16..10977e664eaf 100644
--- a/biology/lamarc/files/patch-src__control__defaults.h
+++ b/biology/lamarc/files/patch-src_control_defaults.h
@@ -1,4 +1,4 @@
---- src/control/defaults.h.orig
+--- src/control/defaults.h.orig 2012-05-01 21:38:26 UTC
+++ src/control/defaults.h
@@ -3,6 +3,7 @@
#ifndef DEFAULTS_H
diff --git a/biology/lamarc/files/patch-src-tools_stringx.h b/biology/lamarc/files/patch-src_tools_stringx.h
index 16d6835a008e..d1ded1a7d8da 100644
--- a/biology/lamarc/files/patch-src-tools_stringx.h
+++ b/biology/lamarc/files/patch-src_tools_stringx.h
@@ -1,6 +1,6 @@
---- src/tools/stringx.h.orig 2012-12-03 12:01:34.000000000 +0100
-+++ src/tools/stringx.h 2012-12-03 12:02:30.000000000 +0100
-@@ -107,6 +107,26 @@
+--- src/tools/stringx.h.orig 2011-04-23 02:02:49 UTC
++++ src/tools/stringx.h
+@@ -107,6 +107,26 @@ struct CIStringCompare : public std::bin
bool ciStringEqual(const std::string& s1, const std::string& s2);
@@ -27,7 +27,7 @@
//------------------------------------------------------------------------------------
template <class T>
-@@ -188,26 +208,6 @@
+@@ -188,26 +208,6 @@ bool FromString(const std::string & in,
DoubleVec1d StringToDoubleVecOrBarf(const std::string& in);