aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-02-10 02:53:12 +0800
committerlinimon <linimon@FreeBSD.org>2017-02-10 02:53:12 +0800
commitd986308550a19d058cd7490871a870e705d8365c (patch)
treebe5801b4b385a04c75cc1baf3b06a46cc4f893e5 /biology
parentb9168d5cd97c323a0847a91c6972bca6948a21a0 (diff)
downloadfreebsd-ports-gnome-d986308550a19d058cd7490871a870e705d8365c.tar.gz
freebsd-ports-gnome-d986308550a19d058cd7490871a870e705d8365c.tar.zst
freebsd-ports-gnome-d986308550a19d058cd7490871a870e705d8365c.zip
Add -fPIC to various ports to enable them to build on armv6.
Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'biology')
-rw-r--r--biology/p5-AcePerl/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/biology/p5-AcePerl/Makefile b/biology/p5-AcePerl/Makefile
index 66126d02b99e..188922db72d1 100644
--- a/biology/p5-AcePerl/Makefile
+++ b/biology/p5-AcePerl/Makefile
@@ -17,17 +17,12 @@ LICENSE_COMB= dual
BUILD_DEPENDS= p5-Cache-Cache>=0:devel/p5-Cache-Cache
RUN_DEPENDS:= ${BUILD_DEPENDS}
-BROKEN_aarch64= Fails to link: unresolvable R_AARCH64_ADR_PREL_PG_HI21 relocation
-
MAKE_JOBS_UNSAFE= yes
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "amd64"
-CFLAGS+= -fPIC
-.endif
+CFLAGS_aarch64= -fPIC
+CFLAGS_amd64= -fPIC
post-patch:
@${SED} -e 's|XX__CC__XX|${CC}|' < ${FILESDIR}/FREEBSD_DEF \
@@ -37,4 +32,4 @@ post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Ace/Freesubs/Freesubs.so
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Ace/RPC/RPC.so
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>