aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-11-07 07:12:14 +0800
committerpav <pav@FreeBSD.org>2004-11-07 07:12:14 +0800
commit875c8579cba9b6bf64611fcdec2679dbbea2a3b8 (patch)
tree2bb302007e546d5490363fab58040d899b120c45 /biology
parent0322f2f90398517b751f76e65d47e978ebd382cc (diff)
downloadfreebsd-ports-gnome-875c8579cba9b6bf64611fcdec2679dbbea2a3b8.tar.gz
freebsd-ports-gnome-875c8579cba9b6bf64611fcdec2679dbbea2a3b8.tar.zst
freebsd-ports-gnome-875c8579cba9b6bf64611fcdec2679dbbea2a3b8.zip
- Fix build on amd64 (crude hack to pass -fPIC to c++ compiles)
Reported by: pointyhat via kris Tested on: arved's box
Diffstat (limited to 'biology')
-rw-r--r--biology/py-biopython/files/patch-setup.py11
1 files changed, 11 insertions, 0 deletions
diff --git a/biology/py-biopython/files/patch-setup.py b/biology/py-biopython/files/patch-setup.py
new file mode 100644
index 000000000000..fdbd92ff3b60
--- /dev/null
+++ b/biology/py-biopython/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig Fri May 14 15:17:43 2004
++++ setup.py Sun Nov 7 01:02:10 2004
+@@ -199,7 +199,7 @@
+ self.compiler.set_executable("linker_so",
+ cxx + ["-shared"])
+ elif build: # fix for 2.3, only if we are making C++ modules
+- self.compiler.compiler_so = self.compiler.compiler_cxx
++ self.compiler.compiler_so = self.compiler.compiler_cxx + ["-fPIC"]
+ else:
+ self.compiler.compiler_so = self._original_compiler_so
+