aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2013-12-19 01:24:51 +0800
committertijl <tijl@FreeBSD.org>2013-12-19 01:24:51 +0800
commit1306b10dac4a67a59e095762ed4d85fe04fbbb5a (patch)
tree43b65733ed5c737264a4e1cc0ab15a80c954acb0 /biology
parent81216e5b4c2e88e3d72a6f396161764be8eca036 (diff)
downloadfreebsd-ports-gnome-1306b10dac4a67a59e095762ed4d85fe04fbbb5a.tar.gz
freebsd-ports-gnome-1306b10dac4a67a59e095762ed4d85fe04fbbb5a.tar.zst
freebsd-ports-gnome-1306b10dac4a67a59e095762ed4d85fe04fbbb5a.zip
USES=fortran, staging.
Diffstat (limited to 'biology')
-rw-r--r--biology/t_coffee/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/biology/t_coffee/Makefile b/biology/t_coffee/Makefile
index 8fdf803c3772..3880798e9703 100644
--- a/biology/t_coffee/Makefile
+++ b/biology/t_coffee/Makefile
@@ -21,22 +21,18 @@ OPTIONS_DEFINE= EXAMPLES
BUILD_WRKSRC= ${WRKSRC}/t_coffee_source
-USE_FORTRAN= yes
+USES= fortran
+CFLAGS+= -Wno-return-type
MAKE_ENV= FCC="${FC} ${FFLAGS}"
MAKEFILE= makefile
PORTEXAMPLES= *
PLIST_FILES= bin/TMalign bin/t_coffee
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
do-install:
(cd ${BUILD_WRKSRC} \
- && ${INSTALL_PROGRAM} TMalign t_coffee ${PREFIX}/bin)
-.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- @(cd ${WRKSRC}/example && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
-.endif
+ && ${INSTALL_PROGRAM} TMalign t_coffee ${STAGEDIR}${PREFIX}/bin)
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC}/example && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>