aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2003-05-19 09:48:33 +0800
committerpetef <petef@FreeBSD.org>2003-05-19 09:48:33 +0800
commitfeac023b42e93e3580d5b7748d545590b8b3a021 (patch)
tree3a1d49fe9852f354151a2a84bff62798cab8f368 /biology
parent4c67d8c6877d3a28df5e4a7394d8d05d0e078573 (diff)
downloadfreebsd-ports-gnome-feac023b42e93e3580d5b7748d545590b8b3a021.tar.gz
freebsd-ports-gnome-feac023b42e93e3580d5b7748d545590b8b3a021.tar.zst
freebsd-ports-gnome-feac023b42e93e3580d5b7748d545590b8b3a021.zip
- fix build under gcc 3.3
- respect CC/CFLAGS PR: 52013 Submitted by: maintainer
Diffstat (limited to 'biology')
-rw-r--r--biology/crimap/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/biology/crimap/Makefile b/biology/crimap/Makefile
index 3899c1007173..6e876cb4e8bc 100644
--- a/biology/crimap/Makefile
+++ b/biology/crimap/Makefile
@@ -16,13 +16,20 @@ MAINTAINER= tonym@biolateral.com.au
COMMENT= Creation of multilocus linkage maps
NO_WRKSUBDIR= true
+USE_REINPLACE= yes
PROGRAMS= crimap
EXAMPLES= chr7a.gen demo.dat
+EXIT_PATCH= e_ped.c get_log.c our_allo.c our_orde.c
+
+post-patch:
+.for file in ${EXIT_PATCH}
+ @${REINPLACE_CMD} -e 's|exit\ *()|exit(0)|' ${WRKSRC}/${file}
+.endfor
do-build:
cd ${WRKSRC}; \
- cc -O -o crimap *.c -lm
+ ${CC} ${CFLAGS} -o crimap *.c -lm
do-install:
.for file in ${PROGRAMS}