aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-01-26 00:48:05 +0800
committermiwi <miwi@FreeBSD.org>2014-01-26 00:48:05 +0800
commit0b45496818c843a86d5f1005d266f71268140bd7 (patch)
tree053bf5e20e7de7a2fdcc1de42f1f354d7991e516 /biology
parentd4b27ea86f2be24f7cb0b6957592181c86aba9e0 (diff)
downloadfreebsd-ports-gnome-0b45496818c843a86d5f1005d266f71268140bd7.tar.gz
freebsd-ports-gnome-0b45496818c843a86d5f1005d266f71268140bd7.tar.zst
freebsd-ports-gnome-0b45496818c843a86d5f1005d266f71268140bd7.zip
- Fix build on -current
- Update MASTER_SITES and WWW: line - Support CXX/CXXFLAGS properly - Support PLIST_FILES - Stage support PR: 184852 Submitted by: Ports Fury
Diffstat (limited to 'biology')
-rw-r--r--biology/ssaha/Makefile28
-rw-r--r--biology/ssaha/files/patch-GlobalDefinitions.h20
-rw-r--r--biology/ssaha/files/patch-SSAHAMain.h12
-rw-r--r--biology/ssaha/files/patch-makefile15
-rw-r--r--biology/ssaha/pkg-descr2
-rw-r--r--biology/ssaha/pkg-plist9
6 files changed, 60 insertions, 26 deletions
diff --git a/biology/ssaha/Makefile b/biology/ssaha/Makefile
index 3e050b5d1348..32c91386444a 100644
--- a/biology/ssaha/Makefile
+++ b/biology/ssaha/Makefile
@@ -3,29 +3,39 @@
PORTNAME= ssaha
PORTVERSION= 3.1c
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= biology
-MASTER_SITES= http://www.sanger.ac.uk/Software/analysis/${PORTNAME:U}/
+MASTER_SITES= ftp://ftp.sanger.ac.uk/pub4/resources/software/ssaha/
DISTNAME= ${PORTNAME}_v${PORTVERSION:S/.//}
MAINTAINER= ports@FreeBSD.org
COMMENT= Very fast matching and alignment of DNA sequences
NO_WRKSUBDIR= yes
+BUILD_WRKSRC= ${WRKSRC}/Binary
-USE_GMAKE= yes
+USES= gmake
+USE_GCC= any
+MAKE_ENV= CCC="${CXX}" OPTIM="${CXXFLAGS}" THREAD_LIB="-pthread"
MAKEFILE= makefile
-BUILD_WRKSRC= ${WRKDIR}/Binary
ALL_TARGET= ssaha
+PLIST_FILES= bin/ssaha %%DATADIR%%/testSSAHA.csh \
+ ${DATA_FILES:S,^,%%DATADIR%%/,}
+PLIST_DIRS= %%DATADIR%%
+
DATA_FILES= test.fasta test_extract.fasta test_filter.fail \
test_filter.fastq test_protein.fasta README
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/ssaha ${PREFIX}/bin
- @${MKDIR} ${DATADIR}
- ${INSTALL_SCRIPT} ${BUILD_WRKSRC}/testSSAHA.csh ${DATADIR}/
- ${INSTALL_DATA} ${DATA_FILES:S,^,${BUILD_WRKSRC}/,} ${DATADIR}/
+ (cd ${BUILD_WRKSRC} && ${INSTALL_PROGRAM} ssaha \
+ ${STAGEDIR}${PREFIX}/bin)
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${BUILD_WRKSRC} && ${INSTALL_SCRIPT} testSSAHA.csh \
+ ${STAGEDIR}${DATADIR})
+.for i in ${DATA_FILES}
+ (cd ${BUILD_WRKSRC} && ${INSTALL_DATA} ${i} \
+ ${STAGEDIR}${DATADIR})
+.endfor
.include <bsd.port.mk>
diff --git a/biology/ssaha/files/patch-GlobalDefinitions.h b/biology/ssaha/files/patch-GlobalDefinitions.h
index fb7851574cc7..49d686d331b5 100644
--- a/biology/ssaha/files/patch-GlobalDefinitions.h
+++ b/biology/ssaha/files/patch-GlobalDefinitions.h
@@ -1,6 +1,16 @@
--- ./Global/GlobalDefinitions.h.orig 2004-03-01 13:51:28.000000000 -0300
+++ ./Global/GlobalDefinitions.h 2008-06-12 15:39:31.000000000 -0300
-@@ -726,8 +726,6 @@
+@@ -79,7 +79,8 @@
+ #include <map>
+ #include <utility>
+ #include <sys/types.h>
+-#include <stdio.h>
++#include <cstdio>
++#include <cstring>
+ #include <sys/file.h>
+ #include <sys/mman.h>
+ #include <sys/stat.h>
+@@ -726,8 +727,6 @@
template <typename T> class Allocator
{
public:
@@ -9,7 +19,7 @@
Allocator( T** ptr, const string& name, ostream& monStream=cerr ) :
ptr_(ptr), name_(name), size_(0), isAllocated_(false),
monStream_( monStream )
-@@ -788,32 +786,34 @@
+@@ -788,32 +787,34 @@
virtual void allocate( unsigned long size )
{
@@ -53,7 +63,7 @@
}
protected:
};
-@@ -892,7 +892,7 @@
+@@ -892,7 +893,7 @@
if (isAllocated_) return;
mode_ = MemoryMapper::createMap;
size_ = size;
@@ -62,7 +72,7 @@
isAllocated_ = true;
}
-@@ -908,7 +908,7 @@
+@@ -908,7 +909,7 @@
if (isAllocated_) return;
mode_ = MemoryMapper::readMap;
size_ = size;
@@ -71,7 +81,7 @@
isAllocated_ = true;
}
-@@ -921,7 +921,7 @@
+@@ -921,7 +922,7 @@
virtual void deallocate()
{
if (!isAllocated_) return;
diff --git a/biology/ssaha/files/patch-SSAHAMain.h b/biology/ssaha/files/patch-SSAHAMain.h
index ee646b476fc1..5cb9234f7c0f 100644
--- a/biology/ssaha/files/patch-SSAHAMain.h
+++ b/biology/ssaha/files/patch-SSAHAMain.h
@@ -1,6 +1,14 @@
--- ./Global/SSAHAMain.h.orig 2004-03-01 13:51:28.000000000 -0300
+++ ./Global/SSAHAMain.h 2008-06-12 15:39:31.000000000 -0300
-@@ -131,7 +131,7 @@
+@@ -41,6 +41,7 @@
+ #include <string>
+ #include <iostream>
+ #include <memory>
++#include <cstdlib>
+ class SequenceReaderMulti;
+ class SequenceReader;
+ class HashTable;
+@@ -131,7 +132,7 @@
-1, // int queryEnd;
-1, // int wordLength;
-1, // int stepLength;
@@ -9,7 +17,7 @@
1, // int minToPrint;
-1, // int maxGap;
0, // int maxInsert;
-@@ -174,6 +174,7 @@
+@@ -174,6 +175,7 @@
CommandLineArg( const string& nameLong, const string& nameShort ) :
nameLong_( nameLong ), nameShort_( nameShort ) {}
diff --git a/biology/ssaha/files/patch-makefile b/biology/ssaha/files/patch-makefile
index 0154077a92ce..cc9cf1a7d330 100644
--- a/biology/ssaha/files/patch-makefile
+++ b/biology/ssaha/files/patch-makefile
@@ -13,3 +13,18 @@
GLOBAL_DIR=${SSAHA_TOP_DIR}/Global
SEQ_DIR=${SSAHA_TOP_DIR}/SequenceReader
+@@ -22,12 +22,12 @@
+ QUERY_DIR=${SSAHA_TOP_DIR}/QueryManager
+ EXEC_DIR=${SSAHA_TOP_DIR}/Executables
+
+-CCC = g++
++CCC ?= g++
+ # !!!! change -g to -O3 before making deliverable %%%%
+ # NB use -ggdb to get gdb to work
+ INCLUDE_PATHS = -I${SSAHA_TOP_DIR} \
+ -I${GLOBAL_DIR} -I${SEQ_DIR} -I${HASH_DIR} -I${QUERY_DIR}
+-OPTIM = -O3
++OPTIM ?= -O3
+ DEBUG_LEVEL =
+ # DEBUG_LEVEL = -DEBUG_LEVEL1
+ # -D_REENTRANT necessary for thread safety - see pthread man page - TC 24.9.1
diff --git a/biology/ssaha/pkg-descr b/biology/ssaha/pkg-descr
index 97d3b05a3d8d..3bebc87679f1 100644
--- a/biology/ssaha/pkg-descr
+++ b/biology/ssaha/pkg-descr
@@ -8,4 +8,4 @@ SSAHA: a fast search method for large DNA databases (2001).
Ning Z, Cox AJ, Mullikin JC. Genome Res. 11: 1725-9.
PMID: 11591649
-WWW: http://www.sanger.ac.uk/Software/analysis/SSAHA/
+WWW: http://www.sanger.ac.uk/resources/software/ssaha/
diff --git a/biology/ssaha/pkg-plist b/biology/ssaha/pkg-plist
deleted file mode 100644
index c1b49b17ae24..000000000000
--- a/biology/ssaha/pkg-plist
+++ /dev/null
@@ -1,9 +0,0 @@
-bin/ssaha
-%%DATADIR%%/testSSAHA.csh
-%%DATADIR%%/test.fasta
-%%DATADIR%%/test_extract.fasta
-%%DATADIR%%/test_filter.fail
-%%DATADIR%%/test_filter.fastq
-%%DATADIR%%/test_protein.fasta
-%%DATADIR%%/README
-@dirrmtry %%DATADIR%%