aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-08-05 20:18:41 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-08-05 20:18:41 +0800
commit4c7e0ad3e268c271d7975fdec548a4d9efc9886e (patch)
tree8272c081e248ef65647b9cc02bd50c521401d2c8 /biology
parent563f77997272df47999eb939ae5768f803575da4 (diff)
downloadfreebsd-ports-gnome-4c7e0ad3e268c271d7975fdec548a4d9efc9886e.tar.gz
freebsd-ports-gnome-4c7e0ad3e268c271d7975fdec548a4d9efc9886e.tar.zst
freebsd-ports-gnome-4c7e0ad3e268c271d7975fdec548a4d9efc9886e.zip
Fix build on mips by properly respecting compiler and flags
Diffstat (limited to 'biology')
-rw-r--r--biology/mummer/Makefile9
-rw-r--r--biology/mummer/files/patch-Makefile20
2 files changed, 20 insertions, 9 deletions
diff --git a/biology/mummer/Makefile b/biology/mummer/Makefile
index 1df3fc503670..9d3b56bc5d00 100644
--- a/biology/mummer/Makefile
+++ b/biology/mummer/Makefile
@@ -22,15 +22,6 @@ DOCUMENTS= COPYRIGHT INSTALL LICENSE README
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
-post-extract:
- @${REINPLACE_CMD} -e 's,type perl,type ${LOCALBASE}/bin/perl,' ${WRKSRC}/scripts/Makefile
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000024
- @${REINPLACE_CMD} -e 's,type gcc,type clang,' ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e 's,type g++,type clang++,' ${WRKSRC}/Makefile
-.endif
-
do-install:
${INSTALL_PROGRAM} ${PROGRAMS:S|^|${WRKSRC}/|} ${STAGEDIR}${PREFIX}/bin
${INSTALL_SCRIPT} ${SCRIPTS:S|^|${WRKSRC}/|} ${STAGEDIR}${PREFIX}/bin
diff --git a/biology/mummer/files/patch-Makefile b/biology/mummer/files/patch-Makefile
new file mode 100644
index 000000000000..96948037b961
--- /dev/null
+++ b/biology/mummer/files/patch-Makefile
@@ -0,0 +1,20 @@
+--- Makefile.orig 2015-08-05 01:03:53 UTC
++++ Makefile
+@@ -35,16 +35,11 @@ SCRIPT_DIR := $(TOP_DIR)/scripts
+ TIGR_SRC_DIR := $(TOP_DIR)/src/tigr
+ KURTZ_SRC_DIR := $(TOP_DIR)/src/kurtz
+
+-CC := $(filter /%,$(shell /bin/sh -c 'type gcc'))
+-CXX := $(filter /%,$(shell /bin/sh -c 'type g++'))
+ SED := $(filter /%,$(shell /bin/sh -c 'type sed'))
+ CSH := $(filter /%,$(shell /bin/sh -c 'type csh'))
+-PERL := $(filter /%,$(shell /bin/sh -c 'type perl'))
++PERL := ${LOCALBASE}/bin/perl
+ AR := $(filter /%,$(shell /bin/sh -c 'type ar'))
+
+-CXXFLAGS = -O3
+-CFLAGS = -O3
+-LDFLAGS =
+
+ FLATS = ACKNOWLEDGEMENTS COPYRIGHT INSTALL LICENSE Makefile README ChangeLog
+