aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-12-04 23:27:29 +0800
committermat <mat@FreeBSD.org>2017-12-04 23:27:29 +0800
commit5b591e35ba114d43933ef4432935d67bbcb43389 (patch)
tree4444037446311bfecadaa5643d6e4f97789ae325 /biology
parent5a22065ca4d16764f8abf2bce0b434b145404d4d (diff)
downloadfreebsd-ports-gnome-5b591e35ba114d43933ef4432935d67bbcb43389.tar.gz
freebsd-ports-gnome-5b591e35ba114d43933ef4432935d67bbcb43389.tar.zst
freebsd-ports-gnome-5b591e35ba114d43933ef4432935d67bbcb43389.zip
Add a USES=python:env, that will not add a dependency on Python.
It has the same effect than setting PYTHON_NO_DEPENDS, but in a more compact way. Sponsored by: Absolight
Diffstat (limited to 'biology')
-rw-r--r--biology/bcftools/Makefile3
-rw-r--r--biology/samtools/Makefile3
2 files changed, 2 insertions, 4 deletions
diff --git a/biology/bcftools/Makefile b/biology/bcftools/Makefile
index 7f3f88d1a42c..de067fb8093b 100644
--- a/biology/bcftools/Makefile
+++ b/biology/bcftools/Makefile
@@ -20,9 +20,8 @@ CONFLICTS_BUILD=openssl
USE_GITHUB= yes
GH_ACCOUNT= samtools
-USES= autoreconf gmake perl5 python shebangfix
+USES= autoreconf gmake perl5 python:env shebangfix
USE_PERL5= test
-PYTHON_NO_DEPENDS= yes
GNU_CONFIGURE= yes
SUB_FILES= pkg-message
SHEBANG_FILES= misc/* test/test.pl
diff --git a/biology/samtools/Makefile b/biology/samtools/Makefile
index da12548a1714..c8e8578e92f7 100644
--- a/biology/samtools/Makefile
+++ b/biology/samtools/Makefile
@@ -17,9 +17,8 @@ TEST_DEPENDS= bash:shells/bash
USE_GITHUB= yes
-USES= autoreconf gmake ncurses perl5 python shebangfix
+USES= autoreconf gmake ncurses perl5 python:env shebangfix
USE_PERL5= test
-PYTHON_NO_DEPENDS= yes
GNU_CONFIGURE= yes
SUB_FILES= pkg-message
SHEBANG_FILES= misc/*.pl misc/*.py misc/plot-bamstats test/test.pl