aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authorjwb <jwb@FreeBSD.org>2018-04-04 04:57:05 +0800
committerjwb <jwb@FreeBSD.org>2018-04-04 04:57:05 +0800
commit79e55e9a65db3bc66b6460f11b1e6d7beeae3fc6 (patch)
treea0d508175a8de3b02706eee236b6988159598b6b /biology
parent584e40cc6c255dc6e69862cc9e0b87ff15457d3b (diff)
downloadfreebsd-ports-gnome-79e55e9a65db3bc66b6460f11b1e6d7beeae3fc6.tar.gz
freebsd-ports-gnome-79e55e9a65db3bc66b6460f11b1e6d7beeae3fc6.tar.zst
freebsd-ports-gnome-79e55e9a65db3bc66b6460f11b1e6d7beeae3fc6.zip
biology/seqtk: Tool for processing sequences in FASTA/FASTQ format
Approved by: jrm Differential Revision: https://reviews.freebsd.org/D14954
Diffstat (limited to 'biology')
-rw-r--r--biology/Makefile1
-rw-r--r--biology/seqtk/Makefile21
-rw-r--r--biology/seqtk/distinfo3
-rw-r--r--biology/seqtk/files/patch-Makefile20
-rw-r--r--biology/seqtk/pkg-descr6
5 files changed, 51 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index 9ece6c0a691f..5c013b34401b 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -106,6 +106,7 @@
SUBDIR += seqan-apps
SUBDIR += seqan1
SUBDIR += seqio
+ SUBDIR += seqtk
SUBDIR += seqtools
SUBDIR += sim4
SUBDIR += slclust
diff --git a/biology/seqtk/Makefile b/biology/seqtk/Makefile
new file mode 100644
index 000000000000..b625d561742f
--- /dev/null
+++ b/biology/seqtk/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= seqtk
+DISTVERSION= 1.2-8
+DISTVERSIONSUFFIX= -gd210c57
+CATEGORIES= biology
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Tool for processing sequences in FASTA/FASTQ format
+
+LICENSE= GPLv2
+
+USE_GITHUB= yes
+GH_ACCOUNT= lh3
+
+PLIST_FILES= bin/seqtk
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/seqtk ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/biology/seqtk/distinfo b/biology/seqtk/distinfo
new file mode 100644
index 000000000000..430869c941bf
--- /dev/null
+++ b/biology/seqtk/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522780777
+SHA256 (lh3-seqtk-1.2-8-gd210c57_GH0.tar.gz) = 557317aab7f8cc306a98cd1148449f1e2edd7cd7c78ad5254ba955dfee518fa0
+SIZE (lh3-seqtk-1.2-8-gd210c57_GH0.tar.gz) = 21166
diff --git a/biology/seqtk/files/patch-Makefile b/biology/seqtk/files/patch-Makefile
new file mode 100644
index 000000000000..6d8f5ee8535d
--- /dev/null
+++ b/biology/seqtk/files/patch-Makefile
@@ -0,0 +1,20 @@
+--- Makefile.orig 2017-11-07 19:42:14 UTC
++++ Makefile
+@@ -1,10 +1,11 @@
+-CC=gcc
+-CFLAGS=-g -Wall -O2 -Wno-unused-function
++CC ?= gcc
++CFLAGS ?= -g -Wall -O2 -Wno-unused-function
++LDFLAGS += -lz -lm
+
+-all:seqtk
++all: seqtk
+
+-seqtk:seqtk.c khash.h kseq.h
+- $(CC) $(CFLAGS) seqtk.c -o $@ -lz -lm
++seqtk: seqtk.c khash.h kseq.h
++ $(CC) $(CFLAGS) seqtk.c -o $@ $(LDFLAGS)
+
+ clean:
+- rm -fr gmon.out *.o ext/*.o a.out seqtk trimadap *~ *.a *.dSYM session*
++ rm -fr gmon.out *.o ext/*.o a.out seqtk trimadap *~ *.a *.dSYM session*
diff --git a/biology/seqtk/pkg-descr b/biology/seqtk/pkg-descr
new file mode 100644
index 000000000000..4cc42a9b9b87
--- /dev/null
+++ b/biology/seqtk/pkg-descr
@@ -0,0 +1,6 @@
+Seqtk is a fast and lightweight tool for processing sequences in the FASTA or
+FASTQ format. It seamlessly parses both FASTA and FASTQ files which can also be
+optionally compressed by gzip. It performs basic file conversions and edits
+much like standard Unix tools do with text files.
+
+WWW: https://github.com/lh3/seqtk