aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-04-16 14:38:23 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-04-16 14:38:23 +0800
commitc4aaf4ea167c86a5fd05132e9ff89fea56d1ade0 (patch)
tree38f0bc73ae1cc73cedcc1a22ede26327772fb78b /biology
parent92b67b5ec83dbbffcdde76177af4467027d7de30 (diff)
downloadfreebsd-ports-gnome-c4aaf4ea167c86a5fd05132e9ff89fea56d1ade0.tar.gz
freebsd-ports-gnome-c4aaf4ea167c86a5fd05132e9ff89fea56d1ade0.tar.zst
freebsd-ports-gnome-c4aaf4ea167c86a5fd05132e9ff89fea56d1ade0.zip
- Switch to options helpers
Diffstat (limited to 'biology')
-rw-r--r--biology/psi88/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/biology/psi88/Makefile b/biology/psi88/Makefile
index 0070d2ac4c93..fa55cef40c6d 100644
--- a/biology/psi88/Makefile
+++ b/biology/psi88/Makefile
@@ -13,6 +13,7 @@ COMMENT= Plotting wavefunctions (molecular orbitals) in 3D
USES= fortran tar:Z
MAKE_ARGS= BIN=${STAGEDIR}${PREFIX}/bin
+
PLIST_FILES= bin/PSI1 bin/PSICON bin/PSI2CT bin/PSI2HP bin/PSI2PS bin/PSI2 \
bin/PREPLOT bin/preplot bin/rpsi1 bin/rpsi2 bin/rpsicon
PORTDOCS= README psi88.doc
@@ -26,16 +27,20 @@ post-patch:
@${CP} ${FILESDIR}/Makefile.top ${WRKSRC}/Makefile
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/P*
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/P*
${LN} -s PSI2PS ${STAGEDIR}${PREFIX}/bin/PSI2
${INSTALL_SCRIPT} ${WRKSRC}/unix/preplot ${STAGEDIR}${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/unix/rpsi1 ${STAGEDIR}${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/unix/rpsi2 ${STAGEDIR}${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/unix/rpsicon ${STAGEDIR}${PREFIX}/bin
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/psi88.doc ${STAGEDIR}${DOCSDIR}
- ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>