aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authorwjv <wjv@FreeBSD.org>2002-03-27 22:42:56 +0800
committerwjv <wjv@FreeBSD.org>2002-03-27 22:42:56 +0800
commit39d668c0346e97530288a9e6f9c4fb0d7c9c51a3 (patch)
tree21b1cdf4e1acc6bc8f4e54da5a09876236a16568 /biology
parent1756efabd1de0b9ab1edc671456cd1d4e4ec7bfa (diff)
downloadfreebsd-ports-gnome-39d668c0346e97530288a9e6f9c4fb0d7c9c51a3.tar.gz
freebsd-ports-gnome-39d668c0346e97530288a9e6f9c4fb0d7c9c51a3.tar.zst
freebsd-ports-gnome-39d668c0346e97530288a9e6f9c4fb0d7c9c51a3.zip
Add crimap 2.4, a tool for the creation of multilocus linkage maps.
PR: 35198 Submitted by: Tony Maher <tonym@biolateral.com.au>
Diffstat (limited to 'biology')
-rw-r--r--biology/Makefile1
-rw-r--r--biology/crimap/Makefile40
-rw-r--r--biology/crimap/distinfo1
-rw-r--r--biology/crimap/pkg-comment1
-rw-r--r--biology/crimap/pkg-descr10
-rw-r--r--biology/crimap/pkg-plist6
6 files changed, 59 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index 1de3d9e94a34..2551f00d5a13 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -7,6 +7,7 @@
SUBDIR += chemeq
SUBDIR += clustalw
SUBDIR += coalesce
+ SUBDIR += crimap
SUBDIR += deft
SUBDIR += dna-qc
SUBDIR += emboss
diff --git a/biology/crimap/Makefile b/biology/crimap/Makefile
new file mode 100644
index 000000000000..e5ecc9ad9857
--- /dev/null
+++ b/biology/crimap/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: crimap
+# Date created: 4 December 2001
+# Whom: Tony Maher <tonym@biolateral.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= crimap
+PORTVERSION= 2.4
+CATEGORIES= biology
+MASTER_SITES= http://compgen.rutgers.edu/multimap/crimap/
+DISTNAME= ${PORTNAME}.source
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= tonym@biolateral.com.au
+
+NO_WRKSUBDIR= true
+
+PROGRAMS= crimap
+EXAMPLES= chr7a.gen demo.dat
+
+do-build:
+ cd ${WRKSRC}; \
+ cc -O -o crimap *.c -lm
+
+do-install:
+.for file in ${PROGRAMS}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${file} ${PREFIX}/bin
+.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${DOCSDIR}
+ ${CAT} ${WRKSRC}/progdoc_v2.4 | tbl | eqn -Tlatin1 | nroff -ms -t \
+ > ${DOCSDIR}/progdoc_v2.4
+.for file in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${EXAMPLESDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/biology/crimap/distinfo b/biology/crimap/distinfo
new file mode 100644
index 000000000000..8738c53c87e8
--- /dev/null
+++ b/biology/crimap/distinfo
@@ -0,0 +1 @@
+MD5 (crimap.source.tar.Z) = bd5b445901feb9c1aa3c2926a3dc7353
diff --git a/biology/crimap/pkg-comment b/biology/crimap/pkg-comment
new file mode 100644
index 000000000000..3ce04b017c81
--- /dev/null
+++ b/biology/crimap/pkg-comment
@@ -0,0 +1 @@
+Creation of multilocus linkage maps
diff --git a/biology/crimap/pkg-descr b/biology/crimap/pkg-descr
new file mode 100644
index 000000000000..8af40b581095
--- /dev/null
+++ b/biology/crimap/pkg-descr
@@ -0,0 +1,10 @@
+"The main purpose of CRI-MAP is to allow rapid, largely automated
+construction of multilocus linkage maps (and facilitate the attendant
+tasks of assessing support relative to alternative locus orders,
+generating LOD tables, and detecting data errors)."
+- from the documentation
+
+WWW: http://compgen.rutgers.edu/multimap/crimap/
+
+--
+Tony Maher <tonym@biolateral.com.au>
diff --git a/biology/crimap/pkg-plist b/biology/crimap/pkg-plist
new file mode 100644
index 000000000000..cd57f6bcc5ff
--- /dev/null
+++ b/biology/crimap/pkg-plist
@@ -0,0 +1,6 @@
+bin/crimap
+%%PORTDOCS%%share/doc/crimap/progdoc_v2.4
+%%PORTDOCS%%share/examples/crimap/chr7a.gen
+%%PORTDOCS%%share/examples/crimap/demo.dat
+%%PORTDOCS%%@dirrm share/doc/crimap
+%%PORTDOCS%%@dirrm share/examples/crimap