aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2014-08-27 04:39:05 +0800
committerrene <rene@FreeBSD.org>2014-08-27 04:39:05 +0800
commit539e25e87730b885fa955705af932691247eca18 (patch)
tree13cab44b2b27c1ecefedc576b56d4dc4cb7ef6a0 /biology
parent3111927e2ba63052102b7d1f2f19ef8fc6dc3d8c (diff)
downloadfreebsd-ports-gnome-539e25e87730b885fa955705af932691247eca18.tar.gz
freebsd-ports-gnome-539e25e87730b885fa955705af932691247eca18.tar.zst
freebsd-ports-gnome-539e25e87730b885fa955705af932691247eca18.zip
biology/crux: stage, modernize, add license (BSD[23]CLAUSE), cleanups
PR: 193026 Submitted by: Ports Fury
Diffstat (limited to 'biology')
-rw-r--r--biology/crux/Makefile46
-rw-r--r--biology/crux/files/pkg-install8
-rw-r--r--biology/crux/pkg-descr27
-rw-r--r--biology/crux/pkg-plist28
4 files changed, 63 insertions, 46 deletions
diff --git a/biology/crux/Makefile b/biology/crux/Makefile
index 08f03465fa0f..a21d0a3c3504 100644
--- a/biology/crux/Makefile
+++ b/biology/crux/Makefile
@@ -3,41 +3,49 @@
PORTNAME= crux
PORTVERSION= 1.2.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= biology python
MASTER_SITES= http://www.canonware.com/download/Crux/
MAINTAINER= ports@FreeBSD.org
COMMENT= Software toolkit for phylogenetic inference
-USES= fortran gmake tar:bzip2
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-python=${PYTHON_CMD} --disable-mpi
-USE_CSTD= gnu99
-USE_PYTHON= yes
+LICENSE= BSD2CLAUSE BSD3CLAUSE
+LICENSE_COMB= multi
-OPTIONS_DEFINE= SYS_LINALG
-SYS_LINALG_DESC= Enable system ATLAS/LAPACK
-
-NO_STAGE= yes
+USES= fortran gmake python tar:bzip2
+USE_CSTD= gnu99
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --datadir=${PREFIX}/lib \
+ --with-python=${PYTHON_CMD} \
+ --disable-mpi
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+OPTIONS_DEFINE= SYS_LINALG
+SYS_LINALG_DESC= Enable system ATLAS/LAPACK
+SYS_LINALG_LIB_DEPENDS= libatlas.so:${PORTSDIR}/math/atlas
+SYS_LINALG_CONFIGURE_ENABLE= sys-linalg
+
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MSYS_LINALG}
-CONFIGURE_ARGS+= --enable-sys-linalg
-LIB_DEPENDS+= libatlas.so:${PORTSDIR}/math/atlas
-.else
-CONFIGURE_ARGS+= --disable-sys-linalg
+.if ${OSVERSION} > 900000
+BROKEN_powerpc= Does not build on powerpc-9: error in pthreads
.endif
-.if ${ARCH} == "powerpc" && ${OSVERSION} > 900000
-BROKEN= Does not build on powerpc-9: error in pthreads
-.endif
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|\([[:blank:]]\)\($$(BINDIR)\)|\1$$(DESTDIR)\2| ; \
+ s|\([[:blank:]]\)\($$(DATADIR)\)|\1$$(DESTDIR)\2| ; \
+ s|\(,\)\(@site_packages@\)|\1$$(DESTDIR)\2| ; \
+ s|\([[:blank:]]\)\(@site_packages@\)|\1$$(DESTDIR)\2|' \
+ ${WRKSRC}/Makefile.in
post-install:
- @${PREFIX}/bin/crux -b -q /dev/null
+ @(${FIND} ${STAGEDIR}${PREFIX}/lib/Crux/lib -maxdepth 1 -type f \
+ -name "*.so" | ${XARGS} ${STRIP_CMD})
+ @(${FIND} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR} -maxdepth 3 -type f \
+ -name "*.so" | ${XARGS} ${STRIP_CMD})
.include <bsd.port.mk>
diff --git a/biology/crux/files/pkg-install b/biology/crux/files/pkg-install
new file mode 100644
index 000000000000..c2e494752edd
--- /dev/null
+++ b/biology/crux/files/pkg-install
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+case $2 in
+POST-INSTALL)
+ ${PKG_PREFIX}/bin/crux -b -q /dev/null
+ exit 0
+ ;;
+esac
diff --git a/biology/crux/pkg-descr b/biology/crux/pkg-descr
index 044b39424386..5a27474d58b3 100644
--- a/biology/crux/pkg-descr
+++ b/biology/crux/pkg-descr
@@ -1,18 +1,19 @@
-Crux is a software toolkit for molecular phylogenetic inference. It is
+Crux is a software toolkit for molecular phylogenetic inference. It is
structured as a set of Python modules, which makes it possible to quickly
-develop Python scripts that perform unique, non-canned analyses. Features
+develop Python scripts that perform unique, non-canned analyses. Features
include:
-* Tree log-likelihoods can be computed under a variety of models, including all
- specializations of GTR+I+G and mixture models. Tree likelihoods can be
- computed in parallel via pthreads.
-* Bayesian Markov chain Monte Carlo (MCMC) methods (with Metropolis coupling)
- can sample among non-nested models using reversible model jumps.
-* Crux is capable of simulating character data under any model its likelihood
- engine is capable of.
-* The neighbor joining (NJ) and relaxed neighbor joining (RNJ) implementations
- are among the fastest in existence.
+* Tree log-likelihoods can be computed under a variety of models,
+ including all specializations of GTR+I+G and mixture models. Tree
+ likelihoods can be computed in parallel via pthreads.
+* Bayesian Markov chain Monte Carlo (MCMC) methods (with Metropolis
+ coupling) can sample among non-nested models using reversible model
+ jumps.
+* Crux is capable of simulating character data under any model its
+ likelihood engine is capable of.
+* The neighbor joining (NJ) and relaxed neighbor joining (RNJ)
+ implementations are among the fastest in existence.
* Pairwise distances between sequences can be computed based on percent
- identity, or using methods that correct for multiple hits (Jukes-Cantor,
- Kimura, and logDet).
+ identity, or using methods that correct for multiple hits
+ (Jukes-Cantor, Kimura, and logDet).
WWW: http://www.canonware.com/Crux/
diff --git a/biology/crux/pkg-plist b/biology/crux/pkg-plist
index 2f17b9c68f86..2ec46ccfc5e4 100644
--- a/biology/crux/pkg-plist
+++ b/biology/crux/pkg-plist
@@ -1,12 +1,15 @@
bin/crux
bin/redpoint
bin/MrRogers
+lib/Crux/lib/libCx.so
+lib/Crux/parsers/Fasta.log
+lib/Crux/parsers/Fasta.pickle
%%PYTHON_SITELIBDIR%%/Crux/CTMatrix.so
%%PYTHON_SITELIBDIR%%/Crux/Character.so
%%PYTHON_SITELIBDIR%%/Crux/Config.py
-%%PYTHON_SITELIBDIR%%/Crux/Config.pyo
+@rmtry %%PYTHON_SITELIBDIR%%/Crux/Config.pyo
%%PYTHON_SITELIBDIR%%/Crux/Copying.py
-%%PYTHON_SITELIBDIR%%/Crux/Copying.pyo
+@rmtry %%PYTHON_SITELIBDIR%%/Crux/Copying.pyo
%%PYTHON_SITELIBDIR%%/Crux/DistMatrix/Nj.so
%%PYTHON_SITELIBDIR%%/Crux/DistMatrix/__init__.py
%%PYTHON_SITELIBDIR%%/Crux/DistMatrix/__init__.so
@@ -51,22 +54,19 @@ bin/MrRogers
%%PYTHON_SITELIBDIR%%/Crux/__init__.py
%%PYTHON_SITELIBDIR%%/Crux/__init__.so
%%PYTHON_SITELIBDIR%%/Parsing.so
-share/Crux/lib/libCx.so
-share/Crux/parsers/Fasta.log
-share/Crux/parsers/Fasta.pickle
-@dirrm %%PYTHON_SITELIBDIR%%/Crux/DistMatrix
+@dirrm %%PYTHON_SITELIBDIR%%/Crux/include/Crux/Tree
+@dirrm %%PYTHON_SITELIBDIR%%/Crux/include/Crux/SFMT
+@dirrm %%PYTHON_SITELIBDIR%%/Crux/include/Crux/Mc3
+@dirrm %%PYTHON_SITELIBDIR%%/Crux/include/Crux/DistMatrix
@dirrm %%PYTHON_SITELIBDIR%%/Crux/include/Crux/Crux/DistMatrix
@dirrm %%PYTHON_SITELIBDIR%%/Crux/include/Crux/Crux/Tree
@dirrm %%PYTHON_SITELIBDIR%%/Crux/include/Crux/Crux
-@dirrm %%PYTHON_SITELIBDIR%%/Crux/include/Crux/DistMatrix
-@dirrm %%PYTHON_SITELIBDIR%%/Crux/include/Crux/Mc3
-@dirrm %%PYTHON_SITELIBDIR%%/Crux/include/Crux/SFMT
-@dirrm %%PYTHON_SITELIBDIR%%/Crux/include/Crux/Tree
@dirrm %%PYTHON_SITELIBDIR%%/Crux/include/Crux
@dirrm %%PYTHON_SITELIBDIR%%/Crux/include
-@dirrm %%PYTHON_SITELIBDIR%%/Crux/Mc3
@dirrm %%PYTHON_SITELIBDIR%%/Crux/Tree
+@dirrm %%PYTHON_SITELIBDIR%%/Crux/Mc3
+@dirrm %%PYTHON_SITELIBDIR%%/Crux/DistMatrix
@dirrm %%PYTHON_SITELIBDIR%%/Crux
-@dirrm share/Crux/lib
-@dirrm share/Crux/parsers
-@dirrm share/Crux
+@dirrm lib/Crux/parsers
+@dirrm lib/Crux/lib
+@dirrm lib/Crux