aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-02-17 01:15:31 +0800
committertijl <tijl@FreeBSD.org>2014-02-17 01:15:31 +0800
commitf86cbfadd2dbfab1dc1ea72e5084a23c10b1dc6c (patch)
tree49e521faa408bc4bd163bfb0febf91e262772c1c /biology
parente04e533cf1bc01e44ad69d14d5c6c205e25bfe3a (diff)
downloadfreebsd-ports-gnome-f86cbfadd2dbfab1dc1ea72e5084a23c10b1dc6c.tar.gz
freebsd-ports-gnome-f86cbfadd2dbfab1dc1ea72e5084a23c10b1dc6c.tar.zst
freebsd-ports-gnome-f86cbfadd2dbfab1dc1ea72e5084a23c10b1dc6c.zip
Convert all USE_FORTRAN=yes to "USES=fortran, USE_GCC=yes". In most cases
USE_GCC=yes has been omitted though. Remove USE_FORTRAN handling from bsd.port.mk and bsd.gcc.mk. Minor cleanups in some ports like USE_GMAKE, NOPORTDOCS,... Exp-run: bdrewery Approved by: portmgr (bdrewery)
Diffstat (limited to 'biology')
-rw-r--r--biology/crux/Makefile6
-rw-r--r--biology/plink/Makefile13
-rw-r--r--biology/plink/files/patch-Makefile9
3 files changed, 13 insertions, 15 deletions
diff --git a/biology/crux/Makefile b/biology/crux/Makefile
index b303a7f992bb..b6e7dce08b3e 100644
--- a/biology/crux/Makefile
+++ b/biology/crux/Makefile
@@ -10,22 +10,20 @@ MASTER_SITES= http://www.canonware.com/download/Crux/
MAINTAINER= jasone@FreeBSD.org
COMMENT= Software toolkit for phylogenetic inference
+USES= fortran gmake
USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-python=${PYTHON_CMD} --disable-mpi
USE_CSTD= gnu99
-USE_GMAKE= yes
USE_PYTHON= yes
OPTIONS_DEFINE= SYS_LINALG
SYS_LINALG_DESC= Enable system ATLAS/LAPACK
NO_STAGE= yes
-.include <bsd.port.pre.mk>
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USE_FORTRAN= yes
.include <bsd.port.options.mk>
@@ -43,4 +41,4 @@ BROKEN= Does not build on powerpc-9: error in pthreads
post-install:
@${PREFIX}/bin/crux -b -q /dev/null
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/biology/plink/Makefile b/biology/plink/Makefile
index bfd37ec1e825..a9711e69d1b5 100644
--- a/biology/plink/Makefile
+++ b/biology/plink/Makefile
@@ -3,10 +3,11 @@
PORTNAME= plink
PORTVERSION= 1.07
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= biology science
MASTER_SITES= http://pngu.mgh.harvard.edu/~purcell/plink/dist/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+EXTRACT_SUFX= .zip
MAINTAINER= jwbacon@tds.net
COMMENT= Whole genome association analysis toolset
@@ -15,15 +16,13 @@ LICENSE= GPLv2
LIB_DEPENDS= liblapack.so:${PORTSDIR}/math/lapack
-USES= gmake
-USE_ZIP= yes
-USE_FORTRAN= yes # Make it use the same compiler as lapack
+# We need Fortran LDFLAGS to link with Lapack.
+USES= fortran gmake
PLIST_FILES= bin/plink
-NO_STAGE= yes
do-install:
- ${MKDIR} ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/plink ${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/plink ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/biology/plink/files/patch-Makefile b/biology/plink/files/patch-Makefile
index cb1e7f5fc537..e98b69aa6559 100644
--- a/biology/plink/files/patch-Makefile
+++ b/biology/plink/files/patch-Makefile
@@ -1,15 +1,16 @@
--- Makefile.orig 2009-10-10 11:00:20.000000000 -0500
+++ Makefile 2012-09-07 08:24:26.000000000 -0500
-@@ -26,7 +26,7 @@
+@@ -26,25 +26,25 @@
WITH_WEBCHECK = 1
FORCE_32BIT =
WITH_ZLIB = 1
-WITH_LAPACK =
+-FORCE_DYNAMIC =
+WITH_LAPACK = 1
- FORCE_DYNAMIC =
++FORCE_DYNAMIC = 1
# Put C++ compiler here; Windows has it's own specific version
-@@ -34,17 +34,17 @@
+ CXX_UNIX = g++
CXX_WIN = c:\bin\mingw\bin\mingw32-g++.exe
# Any other compiler flags here ( -Wall, -g, etc)
@@ -18,7 +19,7 @@
# Misc
-LIB_LAPACK = /usr/lib/liblapack.so.3
-+LIB_LAPACK = -L${LOCALBASE}/lib -llapack -lblas -lgfortran
++LIB_LAPACK = ${LDFLAGS} -L${LOCALBASE}/lib -llapack -lblas
# --------------------------------------------------------------------