aboutsummaryrefslogtreecommitdiffstats
path: root/biology
diff options
context:
space:
mode:
authorjrm <jrm@FreeBSD.org>2017-10-22 01:40:18 +0800
committerjrm <jrm@FreeBSD.org>2017-10-22 01:40:18 +0800
commit5ac29a207d7032ac156b4efbca50256c3e2e9bc6 (patch)
treea8bbbe8013f601bcfb6fd06b5ae6af38a2999484 /biology
parente856196c0a31654bc9ca9ad2956c76f06cd82b9e (diff)
downloadfreebsd-ports-gnome-5ac29a207d7032ac156b4efbca50256c3e2e9bc6.tar.gz
freebsd-ports-gnome-5ac29a207d7032ac156b4efbca50256c3e2e9bc6.tar.zst
freebsd-ports-gnome-5ac29a207d7032ac156b4efbca50256c3e2e9bc6.zip
biology/iqtree: Add EXAMPLES option and fix mess with installation of
example files in first commit
Diffstat (limited to 'biology')
-rw-r--r--biology/iqtree/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/biology/iqtree/Makefile b/biology/iqtree/Makefile
index 55a984e11ffe..1d9dddaabbef 100644
--- a/biology/iqtree/Makefile
+++ b/biology/iqtree/Makefile
@@ -3,6 +3,7 @@
PORTNAME= iqtree
DISTVERSIONPREFIX= v
DISTVERSION= 1.6.beta4
+PORTREVISION= 1
CATEGORIES= biology
MAINTAINER= jrm@FreeBSD.org
@@ -18,7 +19,18 @@ USES= cmake compiler:openmp
USE_GITHUB= yes
GH_ACCOUNT= Cibiv
-PLIST_FILES= bin/iqtree example.cf example.nex example.phy models.nex
WRKSRC= ${WRKDIR}/IQ-TREE-${DISTVERSION}
+PLIST_FILES= bin/iqtree
+PORTEXAMPLES= example.cf example.nex example.phy models.nex
+
+OPTIONS_DEFINE= EXAMPLES
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/iqtree ${STAGEDIR}${PREFIX}/bin
+
+do-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/example/* ${STAGEDIR}${EXAMPLESDIR}
+
.include <bsd.port.mk>